Duplticati and VSS are bad friends

I do a lot of backup tests. I want to choose the perfect backup software.

But I have a problem, Duplticati is not copying the files occupied by the process correctly. I will be able to explain.
Example:

  1. take for the test the duplicati itself and the source data is the whole folder of the Chrome browser

  2. as a second program it will be another (free Backupper)
    for backup. I will not call the program whatsoever an advertisement, I respect the developers of duplicati. The 2nd program that I provided as an example it also works with VSS technology.

Final Duplicati: a copy made by duplicati in the working browser does not save any important data.

The outcome of another program Backupper:
it was able to save some important data and the User data folder. This way, I was able to restore a fully working session of the active Chrome browser in 5 minutes.
And Duplicati failed to do that

I understand that my difficult question, Do I need to understand the reason, different copying technology? Or what’s the problem, because VSS technology is the only one in the system. Why duplicati failed and can’t copy all the files in the process

P.S. And I would also like to express my gratitude to the developers. CMS forum it is just perfect very convenient to interact with and write a +10 points reference :blush: :blush: :blush:

I’ll add my message.
I tried VSS on and VSS auto mode.
It didn’t help me

You must run Duplicati elevated in order to use VSS. With VSS it will be able to back up open files.

how do you do that? I have a shortcut configured to run with admin rights

You may be running it as Admin, but that doesn’t mean it’s Elevated. Close Duplicati and try running the shortcut again by right-clicking and “Run As Administrator”. You will get a UAC prompt asking you for permission to run it Elevated. Then try the VSS option again.

Another way is run it as a service:

As my little experience duplicati works fine with VSS even if a couple of times I obtain a warning from backkup job but this happen because the backup job start running while OS made a snapshot (in my system I scheduled a task who create new snapshot every hour - so duplicati should backup data up to date).

If I understand correctly duplicati can’t create a snapshot before start a backup job but only access to the most recent snapshot available. Can anyone confirm this?

Duplicati makes its own snapshot and removes it after the backup job is complete. It does not utilize snapshots you have scheduled yourself for System protection or previous versions.

You may get a VSS snapshot creation error if two programs try to create a new snapshot at the same time. If you get that error a lot, try staggering the schedule of one of the items. (Don’t have both start at exactly 12:00, for instance…) Delaying one by just a minute or two is usually sufficient.

1 Like

Realy? It explain because I can’t find any trace of snapshot in “recent versions tab”… Anyway I used workaround suggested and everything works fine.

I know, a snapshot every hour sounds “exaggerated” and VSS is not a backup, but this gimmick save me waste time nore than once.

@drwtsn32 is there an additional way to find out what VSS is enabled?
I have disabled UAC, I have an admin account. All programs are run as admin by default.

I tried to install and run the Duplicati service, but I lost the configuration file where I had all the tasks. Where did they go?

c:\Users\admin\AppData\Local\Duplicati\
This folder contains sqlite files and config but my Duplicati running through the service does not see my tasks

Read carefully the post who I linked before: it explain the migration procedure (the directory you should copy and where). Of course, first of all, you must stop duplicati-service.

Ephemeral snapshots created by Duplicati or other backup programs won’t show up there.

@drwtsn32 Unfortunately, the problem has not been solved, now I am running duplicati through a service with full rights. But browser files are not copied fully either.
I can’t figure out why.

I need an exact way to find out if VSS + Duplicati mode is working somewhere in the log files

You have the snapshot option enabled in Duplicati, correct? Set --snapshot-policy to on or auto.

Yes, this option is enabled in Auto mode, I also tried to enable On mode

my config Duplicati

--auto-cleanup=true
--full-result=true
--use-block-cache=true
--log-retention=3D
--snapshot-policy=Auto
--allow-sleep=true
--number-of-retries=25
--thread-priority=low
--concurrency-max-threads=0

found a mistake in the log files

2019-08-27 18:55:32 03 - [Warning-Duplicati.Library.Main.Operation.BackupHandler-SnapshotFailed]:
Failed to create a snapshot: Alphaleonis.Win32.Vss.VssObjectNotFoundException: 
The requested object does not exist.
 in Alphaleonis.Win32.Vss.VssBackupComponents.IsVolumeSupported (String volumeName)
 in Duplicati.Library.Common.IO.VssBackupComponents.CheckSupportedVolumes (IEnumerable`1 sources)
 in Duplicati.Library.CommonUmementary
 in Duplicati.Library.Snapshots.WindowsSnapshot..ctor (IEnumerable`1 sources, IDictionary`2 options)
 in Duplicati.Library.Snapshots.SnapshotUtility.CreateWindowsSnapshot (IEnumerable`1 folders, Dictionary`2 options)
 in Duplicati.Library.ain. Operation.BackupHandler.GetSnapshot (String [] sources, Options options)

I think that error is caused by not having the “Microsoft Visual C++ 2017 Redistributable” package installed. Check to see if you have it installed…

The Redistributable C++ package is installed
2015-2019

image

Which version of Duplicati did you install?

here’s a new version I downloaded 30 minutes ago from the official website. Removed the old one and put this version v2.0.4.23-2.0.4.23_beta_2019-07-14

log Recreating database:

Aug 27, 2019 8:33 PM: Backend event: Get - Retrying: duplicati-b0767b4ef8e76422d84b37c28cc6c5407.dblock.zip.aes (944.98 KB)
Aug 27, 2019 8:33 PM: Operation Get with file duplicati-b0767b4ef8e76422d84b37c28cc6c5407.dblock.zip.aes attempt 4 of 25 failed with message: Remote server returned an error: (404) Not found.
Aug 27, 2019 8:33 PM: Backend event: Get - Started: duplicati-b0767b4ef8e76422d84b37c28cc6c5407.dblock.zip.aes (944.98 KB)
Aug 27, 2019 8:33 PM: Backend event: Get - Retrying: duplicati-b0767b4ef8e76422d84b37c28cc6c5407.dblock.zip.aes (944.98 KB)
Aug 27, 2019 8:33 PM: Operation Get with file duplicati-b0767b4ef8e76422d84b37c28cc6c5407.dblock.zip.aes attempt 3 of 25 failed with message: The remote server returned an error: (404) Not found.

Why are you recreating the database? What version did you have before? If it was > 2.0.4.5 then you actually downgraded. 2.0.4.23 has an unfortunate version number. It is basically the same as 2.0.4.5 plus a very minor change. It has confused a lot of people.