Duplticati and VSS are bad friends

I don’t think it’s right to discuss the installation version of this topic as it’s a solution to the VSS problem. Users will get confused then

Reason I asked which version you had is because there was an issue with a particular version in the past where some required component was not installed properly. So it was potentially related.

But yes the issue with version label has nothing to do with your VSS issue. there are threads about it already…

what do I have to do now? Put C++ Redistributable
or go back to the old version, I’m already confused

Use version… and you have C++ Redistributable so that’s not your VSS issue.

Maybe someone else has some ideas!

reinstalled the canary version, so the log saw it related to the problem?

Aug 27, 2019 9:07 PM: Using WMI provider \\localhost\root\virtualization
Aug 27, 2019 9:07 PM: Cannot find any MS SQL Server instance. MS SQL Server is probably not installed.

Unrelated… those notices are normal if you don’t have MS SQL or Hyper-V installed.

reinstalled all the C++ Redist


an error does not go away, how to fix it developers help you to

Snapshot creation is throwing an exception VssObjectNotFoundException The specified volume was not found or was not available.
Does the source volume support snapshots and is it available to the the account/user running duplicati ?

Yes, everything is available, the “c-disk” launch programs under the administrator’s rights. The VSS service itself has the status of automatic launch

What drives are you trying to back up with Duplicati? Just c:? If you try making a manual snapshot (using previous versions tab in Windows explorer) does it work?

I want to make a copy of the RAM DISK I have their stored databases, config files TMP files

If I make a backup with another backuper program, it easily copies all the files, even those that are occupied by other processes. And Duplicati doesn’t want to copy the error that I showed you earlier

you have to decide why this error appears in my windows 7 system
Failed to create a snapshot: Alphaleonis.Win32.Vss.VssObjectNotFoundException:

You are using a RAM Disk? Well that may be your issue - snapshots may not be supported on RAM disks.

You can see if you see your RAM disk in this query (help from Run as administrator Command Prompt):

C:\>vssadmin list volumes /?
vssadmin 1.1 - Volume Shadow Copy Service administrative command-line tool
(C) Copyright 2001-2013 Microsoft Corp.

List Volumes
    - Displays all volumes which may be shadow copied.

    Example Usage: vssadmin List Volumes


If it’s not there, you could ask your RAM disk provider, or do research on whether snapshots can be done.

Possibly your other program isn’t trying VSS, so getting just the files that aren’t locked. Duplicati will work that way by default, but (unlike some backup programs) has VSS, provided your disk can actually do that.

in my logs of three

VSSADMIN 1.1 - Volume Shadow Copy Utility
(C) Microsoft Corporation, 2001-2005.

The path to that is: \\? \ Volume {93a7edb6-8df9-11e9-98af-806e6f6e6963} \
     Volume Name: \\? \ Volume {93a7edb6-8df9-11e9-98af-806e6f6e6963} \
The path to that: D: \
     Volume Name: \\? \ Volume {93a7edb8-8df9-11e9-98af-806e6f6e6963} \
The path to that is: C: \
     Volume Name: \\? \ Volume {93a7edb7-8df9-11e9-98af-806e6f6e6963} \

I have a system that works now. There is a “Drive C” in which I pointed out a hard link to the DISK R (RAM DISK)

and there’s all the files I want to copy. I use Duplicati

I was making a comparison as an experiment:
When copying Duplicati, only 95% of the files were copied.
And I use Backuper 98-99%

First puzzlement is I see lots of web sites saying you can’t hard link across drives. Where would data be?

I suspect that won’t do a VSS snapshot of R: if that’s what you’re expecting, so this is probably still locked files issue. Are you getting warnings? I don’t know why one program has more files. Any filename pattern?

@ts678 @drwtsn32

Whoa, that’s a victory. I found a weakness in copying files.
It turns out that VSS doesn’t understand that copying goes through the DISK RAM and gives an error in the log file. I moved all the files to the DISK-C and everything worked.

Almost all files except locafile LOCK temp-files and other temporary files have been copied.
now I have a question?

Will it be possible to make changes in updates Duplicati so that it could copy from RAM-DISK? If not, then it would be necessary to have warnings in the log files and users would understand the cause of the error.

I think my experience will help other users solve the problem.
And the Duplicati software works great as a Swiss superwatch

It should already be able to copy from RAM disk, subject to inability to use VSS to copy files now locked.

Can you clarify what happened here? The original description was “not copying the files occupied by the process correctly”. Did it ever copy exactly zero RAM disk files? If so, under which conditions was that?

If you’re asking whether Duplicati can raise its percentage to match your other program, need path data.

If you’re asking whether Duplicati can be changed to VSS-copy files without VSS, answer is clearly no…

–snapshot-policy describes how different settings should work. If setting to Auto didn’t make Duplicati fail silently, then that would be contrary to documentation, and you could file an issue giving exact steps, and probably saying what RAM disk software was used (makes it hard to investigate but may also be crucial).

log file after recovery the files were zero size, or the size in kilobytes

* 2019-08-29 21:39:03 +03 - [Warning-Duplicati.Library.Main.Operation.RestoreHandler-PatchingFileLocalFailed]: Failed to patch file: "d:\zzzDuplicati\recovery\User Data\lockfile" with data from local file "c:\Users\admin\AppData\Local\Google\Chrome\User Data\lockfile", message: The process cannot access the file "c:\Users\admin\AppData\Local\Google\Chrome\User Data\lockfile "because this file is being used by another process.
* 2019-08-29 21:39:04 +03 - [Warning-Duplicati.Library.Main.Operation.RestoreHandler-PatchingFileLocalFailed]: Failed to patch file: "d:\zzzDuplicati\recovery\User Data\ShaderCache\GPUCache\data_0 "with data from local file" c:\Users\admin\AppData\Local\Google\Chrome\User Data\ShaderCache\GPUCache\data_0 ", message: The process cannot access the file" c:\Users\admin\AppData\Local\Google\Chrome\User Data\ShaderCache\GPUCache\data_0 "because this file is being used by another process.
* 2019-08-29 21:39:04 +03 - [Warning-Duplicati.Library.Main.Operation.RestoreHandler-PatchingFileLocalFailed]: Failed to patch file: "d:\zzzDuplicati\recovery\User Data\ShaderCache\GPUCache\data_1 "with data from local file" c:\Users\admin\AppData\Local\Google\Chrome\User Data\ShaderCache\GPUCache\data_1 ", message: The process cannot access the file" c:\Users\admin\AppData\Local\Google\Chrome\User Data\ShaderCache\GPUCache\data_1 "because this file is being used by another process.
* 2019-08-29 21:39:04 +03 - [Warning-Duplicati.Library.Main.Operation.RestoreHandler-PatchingFileLocalFailed]: Failed to patch file: "d:\zzzDuplicati\recovery\User Data\ShaderCache\GPUCache\data_2 "with data from local file" c:\Users\admin\AppData\Local\Google\Chrome\User Data\ShaderCache\GPUCache\data_2 ", message: The process cannot access the file" c:\Users\admin\AppData\Local\Google\Chrome\User Data\ShaderCache\GPUCache\data_2 "because this file is being used by another process.

my settings Duplicati


This sounds like a get-a-few-more-files request, so I assume at the moment everything is OK unless log warned. Its lockfile and three cache files might not be important, but did the other program get them OK?

I’m seeing different levels of success between different Windows copying programs copying a lockfile.

copy fails, while xcopy and robocopy work. Creating and Opening Files shows how it’s a bit of a guess to successfully open a file, because it depends on how the program that currently has it open has opened it.

Although I don’t know what Duplicati does, an example would be that GENERIC_READ, FILE_SHARE_READ would fail for some first process open ways where GENERIC_READ, FILE_SHARE_WRITE would succeed, therefore a careful read of the chart might let a few more files be picked up assuming library code allows.

This isn’t a common request. VSS is a more complete solution for in-use Windows files, if it can be used.

Just to let you know that installing Visual C++ worked for me: about three or four out of 15 computers had the VSS problem solved.