Duplicati no longer launching on Mac - database version?


#1

Suddenly, without upgrading the app or making any system changes Duplicati is no longer launching.
If I launch app from terminal I get errors (see below). If I delete Duplicati-server.sqlite file the app works again but all my settings, databases etc are gone.

Crash! 
System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.Exception: A serious error occurred in Duplicati: System.Exception: Failed to create, open or upgrade the database.
Error message: 
The database has version 5 but the largest supported version is 4.

This is likely caused by upgrading to a newer version and then downgrading.
If this is the case, there is likely a backup file of the previous database version in the folder /Users/MacMini/.config/Duplicati.
  at Duplicati.Server.Program.GetDatabaseConnection (System.Collections.Generic.Dictionary`2[TKey,TValue] commandlineOptions) [0x0023b] in <5ce7873446514fd69c1c6b28a3dc0d2

Duplicati not starting on Mac any more
#2

Did you get this resolved yet? If not, what version of Duplicati are you using?


#3

I am using 2.02.20 on a Mac OS X 10.11.6

I got the app to launch again by deleting the Duplicati-server.sqlite file.
I then had lost all my settings. Since I am still in the testing phase, I just deleted the whole backup and started from scratch.
So, yes it is working again, but the way I fixed it is not desired for a real, large backup.


#4

I agree the solution wasn’t great, but I’m glad you got it working.

Unfortunately, with so few (you only?) people running into this (or at least reporting it) it’s tough to dig into possible causes.

I’ve updated the topic title to indicate it’s a “database version” related issue so hopefully if there are others running into this they can chime in.

Please let us know if the error happens to you again (though I’m guessing it won’t)…


#5

There are other users reporting the same issue.



#6

After going through the Github thread above I seem to have found a way around this on a Mac, at least for now.

I deleted all the files in ~/.config/Duplicati/ except backup_xxxxxx.sqlite (my latest backup), which allowed Duplicati to start but without any configured backups.

Closed Duplicati, opened backup_xxxxxx.sqlite in TextEdit and copied the contents into the newly created Duplicati-server.sqlite file. Started Duplicati again, repaired the database and things seem to be back to normal.

Thanks @Monstergerm for linking my thread.


Duplicati not starting on Mac any more
#7

It happened again. Duplicati crashed and is no longer launching. Something about wrong database version. This time I cannot get it to launch again. I deleted sqlite file and tried what Nito suggested, but Duplicati refuses to launch. Very frustrating …


Cannot start Duplicati - "Error: UsageReporter failed"
#8

Just for reference, here’s another database version post:


#9

Had the same problem when moving from Canary to Beta.
To get it working again I changed back to Canary and activated the backup database by renaming it.


#10

I was on Canary and it happened with the latest Canary update. I ran the updater and applied it. The web interface confirmed that I am running the latest update but when I look inside the Duplicati app I see in Info.plist an old version number.
Clicking on the app icon failed with messages like the app is already running or app already quit.
I trashed everything and freshly downloaded the beta version this time. I restored backup configuration from json files and recreated databases. So far it seems to work again.
So something with the update process seems to screw things up. My Update Channel is and always was Default (beta).


#11

There were quite a few changes to the update process between the two betas, and we know some of the changes did cause update failures in some scenarios (though I don’t think we ever pinned down which scenarios).

Hopefully the painful part is over and future updates will go more smoothly now that you’re on the new process. But if not, please let us know.


#12

So I have several computers testing Duplicati right now.
What is the safest way to go forward?

Avoid the Canary updates and stick with the less frequent Beta updates?
What update channel setting?
How do I switch my Canary backups to Beta backups without corrupting the database?


#13

The choice of beta vs. canary channel really depends on how well the channels currently support your needs and how quickly you want access to new features.

If the beta does what you need, I’d suggest you stick with that - though personally I’m using the beta on one machine and canary on all the others I manage.

Switching from canary to beta shouldn’t be problem, particularly right now as they are very close to each other. As long as you aren’t using any canary specific parameters you should be able to do an install of Beta “over” Canary then change your Update channel (on main Settings page) from Canary to Beta (otherwise you’ll be alerted about canary updates you don’t want).

If you’re at all paranoid be sure to export your backup jobs to “To File” just in case something goes wrong, though personally I don’t recall ever needing to re-import a job after an update.

Note that I expect your update issues were more of a one-time thing due to update specific code changes. As far as I know that process is mostly settled now so the problems you had shouldn’t return moving forward.


#14

Good thing I was paranoid and had a backup json file. The switch from canary to beta totally failed.

First I opened my Canary installation, switched to Beta Update channel and checked for new update. None was available (I thought the app would tell me about the latest beta).

Then I quit the Canary app and just for fun relaunched it. App is no longer launching with same database errors in Console log as reported previously.

Then I freshly installed Beta app from a disk image , deleted Canary app and I am still not able to launch Beta app. After I completely delete the content of the Duplicati config folder I can finally launch the Beta app but of course I have to restore all my backup settings and repair the database.

So, maybe this helps figuring out what is going wrong here.


#15

Sorry to hear that - and glad to hear you did back up your json file.

Let us know if you run into any issues with the database repair - and thanks for the detail about the process you had to go through. Hopefully we can align it with some other reports and figure out why it happened.