Duplicati for Synology - Connection lost

Hello forum,
I used duplicati a long time on my win10 machine. (but meanwhile I use Linux)
Now I tried to use it on my two Synology NAS. I use two synology nas. One is the DS215j, the other the
DS214Se. On both i installed newest duplicati package ( in combination with mono ( I read different installation guides like https://forum.duplicati.com/t/how-to-install-duplicati-on-synology-dsm/5145

On the DS215j duplicati runs. On the DS214se I always get a “Connection lost” error.

I read in different posts about, that the user must be in the http group, that it could help to set the “allow remote access” https://forum.duplicati.com/u/drwtsn32. But Iam not fast enough to do this. Before I can save it, duplicati run out of connection, and I can do nothing, but close the window.

I also get the error message once on my DS215j. But then it runs again.

Any ideas?
Thanks in advance.

Yesterday - I dont know why - duplicati started and I was able to create some backup jobs. Today the same error is present again as the one i described above. Iam at a loss.


How much RAM do your NASes have?

Hi drwtsn32,
the one which works with duplicati has 512MB
the other has 256MB.
But when I start duplicati, the ram monitor says only 42%. So it can still be the reason for the problems?

I’m not sure if that’s the issue. I see some old threads where people run Duplicati on a Synology NAS with only 256MB, but that was over 4 years ago. I am not sure what the system requirements are nowadays.

Ok. Thanks, at least it would be an explanation why it doesn’t work.

I have a Synology NAS but it has 16GB RAM so hard for me to test. I’m wondering if I can run an old version of DSM in a VM and customize the RAM to what you have. What version of DSM are you using?

DSM Version is: DSM 6.2.4-25556 Update 6

Ok great, I found how to download older vDSM images. I’ll try to test this out…

Ok, I set up vDMS 6.2.4 but DSM won’t let me configure the VM with less than 1GB RAM.

I installed Mono from SynoCommunity then installed Duplicati I didn’t mess with any settings or group memberships. After starting Duplicati I run the web UI from within DSM itself so that I can enable the “remote access” option. I had no problem doing this and was able to check the box, scroll down, and click OK without the connection getting lost.

My memory usage was 23% without Duplicati running and 30% with Duplicati running (1GB RAM). Just going by that I would think your 512MB model should be ok but not sure about your 256MB model.

Many thanks for your time and your commitment. For me it seems logically, the ram, is probably the problem.