Duplicati crash after running backup


Running Duplicati on Synology Nas. Installed yesterday.
I now have the issue that everytime I run a backup, it seems to work ok. But when it gets to the step “verifying files” I get a connection lost issue. When trying to refresh the browser, I get a warning that the service is down.
I tried to follow this up via SSH. It seems that the job is closed. Following stacktrace appears:

* Assertion at ../../../mono/mini/local-propagation.c:330, condition `ins->opcode > MONO_CEE_LAST' not met


  at <unknown> <0xffffffff>
  at System.Collections.Generic.Dictionary`2<string, int>.Insert (string,int,bool) <0x00066>
  at System.Collections.Generic.Dictionary`2<string, int>.Add (string,int) <0x0001b>
  at MimeKit.Utils.CharsetUtils.AddAliases (System.Collections.Generic.Dictionary`2<string, int>,int,int,string[]) <0x0006c>
  at MimeKit.Utils.CharsetUtils..cctor () <0x0028b>
  at (wrapper runtime-invoke) object.runtime_invoke_void (object,intptr,intptr,intptr) <0x0005a>
  at <unknown> <0xffffffff>
  at (wrapper managed-to-native) object.__icall_wrapper_mono_generic_class_init (intptr) <0x00051>
  at MimeKit.ParserOptions..ctor () <0x000cb>
  at MimeKit.ParserOptions..cctor () <0x00077>
  at (wrapper runtime-invoke) object.runtime_invoke_void (object,intptr,intptr,intptr) <0x0005a>
  at <unknown> <0xffffffff>
  at Duplicati.Library.Modules.Builtin.SendMail.SendMessage (string,string) <0x00157>
  at Duplicati.Library.Modules.Builtin.ReportHelper.OnFinish (object) <0x0074e>
  at Duplicati.Library.Main.Controller.OnOperationComplete (object) <0x0029a>
  at Duplicati.Library.Main.Controller.RunAction<T_REF> (T_REF,string[]&,Duplicati.Library.Utility.IFilter&,System.Action`1<T_REF>) <0x00733>
  at Duplicati.Library.Main.Controller.Backup (string[],Duplicati.Library.Utility.IFilter) <0x002fb>
  at Duplicati.Server.Runner.Run (Duplicati.Server.Runner/IRunnerData,bool) <0x0112f>
  at Duplicati.Server.Program/<>c.<SetWorkerThread>b__45_0 (Duplicati.Server.Runner/IRunnerData) <0x00017>
  at Duplicati.Library.Utility.WorkerThread`1<Tx_REF>.Runner () <0x005c6>
  at System.Threading.ThreadHelper.ThreadStart_Context (object) <0x0009a>
  at System.Threading.ExecutionContext.RunInternal (System.Threading.ExecutionContext,System.Threading.ContextCallback,object,bool) <0x001c6>
  at System.Threading.ExecutionContext.Run (System.Threading.ExecutionContext,System.Threading.ContextCallback,object,bool) <0x00020>
  at System.Threading.ExecutionContext.Run (System.Threading.ExecutionContext,System.Threading.ContextCallback,object) <0x00059>
  at System.Threading.ThreadHelper.ThreadStart () <0x0002e>
  at (wrapper runtime-invoke) object.runtime_invoke_void__this__ (object,intptr,intptr,intptr) <0x000c8>

Native stacktrace:

	/volume1/@appstore/Mono/usr/local/bin/mono-sgen() [0x4ae915]
	/lib/libpthread.so.0(+0x101c0) [0x7eff07d101c0]
	/lib/libc.so.6(gsignal+0x37) [0x7eff0777d907]
	/lib/libc.so.6(abort+0x16a) [0x7eff0777ecda]
	/volume1/@appstore/Mono/usr/local/bin/mono-sgen() [0x6423d9]
	/volume1/@appstore/Mono/usr/local/bin/mono-sgen() [0x6425df]
	/volume1/@appstore/Mono/usr/local/bin/mono-sgen() [0x642726]
	/volume1/@appstore/Mono/usr/local/bin/mono-sgen() [0x47f0a4]
	/volume1/@appstore/Mono/usr/local/bin/mono-sgen() [0x4f8560]
	/volume1/@appstore/Mono/usr/local/bin/mono-sgen() [0x4f8e29]
	/volume1/@appstore/Mono/usr/local/bin/mono-sgen() [0x4273ba]
	/volume1/@appstore/Mono/usr/local/bin/mono-sgen() [0x4b018f]
	/volume1/@appstore/Mono/usr/local/bin/mono-sgen() [0x4b0b0f]

Debug info from gdb:

Got a SIGABRT while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries 
used by your application.

Judging from the stacktrace the problem is caused by the logic that sends the mail at the end to inform the status.
I did a test restore - it works. However, in the main screen, the last successful backup is not updated; it remains to the old value from the old Duplicati version.

So what is wrong? How can it be solved?

Update: I disabled the email warning functionality and now it works ok.
So indeed, the problem is in the email sending.
Can this be solved? I am running the backups in a scheduled way and it’s easier for me to follow this up via email than logging into the Nas.

Does below very-similar-looking (compare stack trace at top to yours) situation and solution help?
I don’t have a Synology, but there’s a forum volunteer who does (and might also suggest Docker).

How can I disable this without a running duplicati server?

Welcome to the forum @I.with

Can you clarify that? How do you have a crash after running backup in that case?
If you need to stop a backup that starts at start, use Stop after current file.
Regardless, Duplicati *should* be down if your Synology requires a mono update.
After that, you should have no need to disable anything. Please clarify situation…

thanks for your answere!

duplicati crashed when i initiated an update by the web frontend and could not be started again.
I tried the restart hours later, so i think duplicati immediately started an incremental backup with mail notification. Thus i had no chance to configure by the web frontend.

I finally could install a newer mono version, now duplicati is running again.

1 Like