Duplicati Auth Issues with Sia-UI Network issues since 1.3.4


#1

Hi,
Does anyone knows about Duplicati Authentifications Issues with Sia-UI Network issues since 1.3.4

Sia 1.3.7 is out and the issue remains.

Even applying in siad.exe command line: --authenticate-api=false Duplicati will not work.

Can this be fixed please?

If someone made it work with latest Canary version of Duplicati, please post tips or workarround. It’s been 1½ months my backups are broken.

Thanks
Dan


#2

Hi @DanSir, welcome to the forum!

It sounds like you previously were getting successful Duplicati backups to Sia until they updated to 1.3.4, is that correct?

Not that it likely matters, but what version of Duplicati are you using, on what OS, and are you doing anything crazy like @TitaniumCoder477 (Sia backup gateway appliance)?

If you’re just using it as a standard destination, hopefully another Sia user such as @drakar2007 or @evlvd (Sia 1.3.6 API Password Integration) might have some thoughts.


#3

For the record, SIA backups work fine for me as long as i start the SIA GUI using the method discussed in that other thread (which is a pain, but works at least).


#4

Thanks for sharing that - hopefully @DanSir can confirm that works for him too (though obviously not an actual solution).


#5

Hi Jon,

Was working perfectly for months, I used to backup on Azure… Was happy for performance and princing with SIA.

I’m currently running SIA-UI 1.3.7 with Duplicati - 2.0.3.14_canary_2018-11-08, hopping every updates will fix my issue.
My os is Win10x64, no gateway involved.

I tried a few things, the one that almost work was when I call SIAD.exe with --authenticate-api=false
The only issue, can’t restore, anyone tried this? Never had issues restoring or verifying files before. since 1.3.4 my backup arent working. Even tried a new backup with all options of 4 files on my desktop., as usual since the upgrade : failing

Thanks for the help
Dan


#6

What happens when you try?


#7

Nothing, job start and never end…


#8

Anything happening in the Duplicati logs (try profiling view for super verbose info), or in the SIA GUI? I’ve had issues with SIA itself before where a backup would stall at “verifying” because the download of the verification dblock would stall in SIA and duplicati would never figure it out. But this is 100% a SIA problem, nothing to do with Duplicati as far as I can tell. But without more troubleshooting info it’s hard to guess what your particular issue might be.


#9

Sorry Guy’s, I left the topic, been two months since I have no Backup and SIA looks likes it’s completly Fu?/Up…

In the past week I’ve been moving my backups to another Cloud provider until Duplicati and SIA is more mature.

All my files in the SIA Network are 0.3x replicated, everyday I loose stuff. Until then, I’ll put my offline backups somewhere more reliable… Too bad, it was working fine until 1.3.4.

I should not be the only one having issues with SIA, I even tried putting regular document in a new folder in SIA and replication doesn’t happen, is this only me experiencing this or is it globally? If it’s only me, I’ll delete my content on SIA and restart over again, but if I’m not alone, I’ll simply wait.

Waiting for proper feedback on SIA user experience.

Thanks
Dan


#10

Have you confirmed you have enough SC in your wallet & allocated for file storage? In my limited experience, if the allocation runs too low, document transfers will start acting quirky.


#11

I have 1000 SC left and contract of 200SC is active and 147SC left. Contract is fine.
it ain’t the contracts. either my data is corrupted or issues with SIA. Can’t pin point it.
Thanks
Dan


#12

Gotcha, thanks. Yeah it sounds like your issues are on the SIA side and nothing really to do with Duplicati. I’ve had similar issues with SIA in the past while trying to run test duplicati backups / restores - SIA will go to download a piece and stall at 99% and never finish, and Duplicati never moves on. Pretty frustrating. Regarding your file transfer issues directly to the SIA client, I hope you might go to the SIA forums and/or subreddit and ask for feedback from them directly.


#13

Totally SIA issue, I was hopping someone had experince this before… here is an update for the community:
I deleted all my files on SIA and restarted a new Duplicati Backup but instead of 500MB like the tutorial says, mine is 100MB… running like a cham so far.

I also create a Schedule Task on Windows 10 to run at machine startup sith SYSTEM account with these settings:
RUN: %userprofile%\Sia-UI\resources\app\Sia\siad.exe
Parameters: --sia-directory “%userprofile%\AppData\Roaming\Sia-UI\sia” --authenticate-api=false

PS: Don’t forget to unlock your wallet from time to time otherwise you won’t be able to create new contracts. Once unlocked, I can close SIA-UI and quit sicne it’s CPU intensive without affecting my backups and reduce RAM ressources as well…

I’m currently running SIA-UI 1.3.7 with Duplicati - 2.0.4.5_beta_2018-11-28

I’m glad it’s back to normal, I hope SIA won’t create another issue like that.

Dan