Duplicati and VSS


#1

I’m wondering if anyone can clarify how Duplicati and VSS should be working together. I want to back up my Outlook .ost files, however Duplicati only successfully backs them up when Outlook is not running.

I just re-imaged a laptop with the Windows 10 image provided by Microsoft, fully patched it, and installed Duplicati. By default, the VSS service is not running and set to “Manual” (maybe that’s typical?). I turned it on, but no change. I’m running Duplicati as a service with the local system account.

I’m just curious if this is expected behavior or there’s a setup step I’m missing to enable the use of VSS.

Thanks,
Mike


#2

Under Settings, Default Options set the “snapshot-policy” to either “on” or “auto” - I always set it to “on”. I also recommend setting “usn-policy” to “on” if your backup is running under and admin account.


#3

For what it’s worth, OST files don’t need to be backed up. OST file is an offline cache of your Exchange/ActiveSync mailbox. It will be redownloaded if the file is ever lost or corrupt. I configure Duplicati to skip OST files.

PST files are a different story and should be backed up. You’ll need to enable the snapshot feature as Taomyn mentioned if you want to back those up while Outlook is running.


#4

In addition to the good general settings from @Taomyn , please note that VSS might not snapshot .ost files, and it appears to be the actual Outlook design intent. You can use a search engine to read more on ost vss.
Backup does not contain ost files is a previous forum thread. To be most sure this is it, watch your registry… Though I can’t test here, I wonder if Outlook removes that FilesNotToSnapshot entry when it’s not running?


Starting Duplicati when Windows is shut down
#5

That’s a good point about backing up .ost. It’s not a critical thing – I just tend to backup email in general. In Apple Mail and Thunderbird, I’ve always backed up mbox files just in case.

I think you’re right that .ost’s are not included in the snapshot. After enabling snapshot-policy, I see the shadow getting created, but the file is not in the subsequent Duplicati snapshot to restore.

However, at least VSS is now being used, which was really my bigger concern. It does seem to create a new (very minor) issue with some files failing because the path is longer than 240 characters (presumably because the VSS path to certain files is longer than the non-VSS path), but these appear to be .db files in AppData I don’t care about.

Thanks,
Mike


#6

might help your long path problems, but the fix is only in canary (you can experience new fixes and bugs). One fix was for the combination of USN and long paths, so you could try turning off –usn-policy (if it’s on).
Issue 3311 PathTooLongException when using USNJournal #3456