[Solved] Cannot perform a differential backup for database “XYZ”, because a current database backup does not exist

Hi All, I’ve run into this interesting problem and after searching the internet realised that the problem is not very common. But luckily a few sites have reported on the solution, but in the context of other backup solutions.

This problem is not really a Duplicati problem, but Duplicati plays a role in it which causes one to think that Duplicati is at fault.

I’ve got a separate process of backing up Full and Diff copies of my dbs. This process ran fine, until I enabled the VSS (Volume Shadow Copy Service) option in Duplicati.

Even though I’m not using Duplicati to backup my dbs or their files (*.mdf or *.ldf), this problem persisted every time I ran ANY backup in Duplicati (that uses the VSS option… in my case all of them).

What would happen is that once I ran the Duplicati backup any previously “Full” backups that was taken of the SQL Server dbs was void, and any Diff backup after this, would always fail with the error:

“Cannot perform a differential backup for database “XYZ”, because a current database backup does not exist.”

The solution was provided by another site:
Cannot perform a differential backup because current backup does not exist

It was also hinted here, but the above article gave the solution as well:

The solution to this problem is to simply go to “services” and change the option of the “SQL Server VSS Writer” to not start “Automatically” but rather “Manual”. And to also stop it, here is a screenshot of mine, this is before I made these changes:

I hope this helps someone in the future as it can easily be seen as a fault or problem in Duplicati. I would also suggest that if possible, Duplicati should “check” this service’s settings and warn the user if it sees that it is set to run Automatically.

Thank you!

Thanks for sharing!

I have never tried using Duplicati to back up SQL, but this seems like a bug for sure. Duplicati shouldn’t be trying to do any SQL VSS stuff unless you’ve actually selected SQL databases for backup.

vss-exclude-writers might offer you some relief. I don’t know this area, so won’t comment on is-it-a-bug.