Corrupt database unable to run new backup

hi, I have backups that span for quite some time and I am unable to create a new because it states the database is corrupt. I have tried to run the delete and create database option and it always ends up freezing at the same spot. When i select to stop I end up getting errors -
remote file referenced as xys but not found in list registering a missing remote file and failed to process index file.
how can I fix this and have a I lost my old backups ?

Welcome to the forums.

First off, providing you have the backup files and the passphrase (if used) you should be able to restore your data. From the restore menu select the “Direct restore from backup files…” and follow the prompts from there. Probably not quite what you’re looking for but good know in a worse case situation.

As for the database being corrupt we’re probably going to need a bit more info. Can you still see the job in the GUI, are you using the GUI? Is Duplicati running as a service? Do you have other jobs defined and do they work?

Thanks Jimbo! Will keep that in mind in the event its needed, but would like to fix it so new updates remain under that same job.
I’m using the GUI and the job is still running. Whenever I try to run it again to get a new version, the above errors happen. Duplicati is running as a service that starts with windows and this is the only job I have.

Could you please give the exact message for below? I can’t find that exact one.

Was this the first sign of trouble, or is this where you are now after having tried various things?
Please give any history you recall on what the very first problem was before attempting any fix.
Do you by any chance have any separate log, or a copy of the database before you deleted it?

Are you coming back to an old backup after a long break, or was backup current but just broke?

You wrote “errors” in the plural. Is xys just a placeholder for various ones? How many are there?

Although I hope it’s not needed, an even better tool for worst case scenario doesn’t use such files:


This tool can be used in very specific situations, where you have to restore data from a corrupted backup. The procedure for recovering from this scenario is covered in Disaster Recovery.

Please watch a live log at About → Show log → Verbose and post the top few lines at freeze point.

Ordinarily I think it goes through the dlist files, the dindex files, then (if still needed) the dblock files.
The dblock files are on the final 30% on progress bar, and the final 10% can take a very long time, depending on backup size, download rate, etc. Easiest evidence of non-freeze is probably live log.

What storage type is your destination, and can you easily examine and obtain its files, if need be?
If you can conveniently sort by date, what sorts of files (if any) are the newest? Any near fail date?
Generally a backup will upload 50 MB dblock files and much smaller dindex, with a dlist at the end.