Connection to server is lost (Synology)

I’m running Duplicati on a Synology NAS for a while now with no issues.

Today when I tried to check a few things, the web GUI shows:
Connection to server is lost, attempting again in…

Connecting directly to port 8200, is not possible.
Synology Package center is showing Duplicati is “running”.

I stopped/started the service. No change.
I restarted the NAS. No change

I uninstalled Duplicati and re-installed, this time version 2.0.5.1 (I don’t know what version it was before).
Via Synology package, still the same issue

Via command line: mono /volume1/@appstore/Duplicati/Duplicati.Server.exe --webservice-interface=* works

What can I try to find out what the issue is with the Synology package?

Never mind. It works again. After running a backup from the command line I later started the Synology package again and it just worked. Nothing changed. Don’t ask me what that was.

Are you using the Mono package from the official Synology package repository? If so, it is really old (4.x) and is insufficient for Duplicati versions 2.0.5.x and later. It MAY be related to the problems you are seeing.

If you are using mono 4.x then I recommend stopping Duplicati, stopping Mono, then uninstalling the Mono package. Install the Mono package from https://synocommunity.com then restart the Duplicati package.

Hope this helps, and welcome to the forum!

Had again the same issue:
Connection to server is lost. Stopped the Synology package, started Duplicati server via command line which worked.
Then stopped the Duplicati server again, started via Synology package, again no connection to server possible.
Then stopped the Synology package again, started server via command line, then started a backup task manually, then stopped server and started Synology package again -> worked!

Mono version is 5.20.1.34-13 (SynoCommunity package)

I really wonder what’s happening. At least I have a (although complicated) workaround now…

Hello,
Still the same error ?
I think there is something who are change.
I have the same error.