Connect to Synology NAS (target) fails when trying to set up a task (docker on NAS)

On my new DS220+ (DSM 7) I successfully installed Duplicati into Docker, thanks to the clear instructions I found here: Container runs OK and I can access Duplicati’s config page via http://MyNas1:8200/ngax/index.html.
Source files are on MyNas1 (DS 220+), target is my old DS 211j: MyNas2 (DSM6.2.4).
On both systems I started up WebDAV-Server with ports 5005 and 5006, configured firewall to open these ports and on MyNas2 I created a special user account for duplicati, including permissions for WebDAV.

In Duplicati however I don’t get past step 2, setting up the backup destination: I specified WebDAV as storage type, entered correct IP for MyNas2 with port 5005 and credentials of my duplicati user onMy Nas2.
When I test the connection I get error 405 (Method not allowed) indicating that the NAS doesn’t accept WebDAV connections.
I more or less randomly picked WebDAV as storage type, maybe I should use another one altogether?

I may have missed a setup on the NAS side, so this might actually be a question to the Syno folks - but hopefully someone here already ran into the same problem and can help.

I use WebDAV on my Synology NAS. It was the first thing I tried and I’ve never had any issues with it, so I haven’t bothered trying anything else.

Sounds like you correctly granted this user access to the “WebDAV server” application in Synology. But did you also make sure it also has access to the shared folder/directory where you’re trying to save your data?

Hmmm … .dumb question: Where else do I need to look? Checking permissions for this user in control panel I find it is the only user who has access to the target folder and it has explicit permissions granted for WebDAV Server. Do I need permissions in some other place?
However even if I had missed anything in the permissions to the folder, I would have expected a different error message than 405 (Method not allowed), which seems to block access to the system altogether.

I’m referring to filesystem level permissions directly. You can adjust those in File Station by viewing the Properties of a folder. Here’s what mine looks like when I go to /Backups/Duplicati/<folder1> and click properties:

Here I granted my duplicati4 user read and write access to this folder and all subfolders.

That could very well be the case. I’m not sure what error is thrown when the user doesn’t have permission to the target. I didn’t test that yet, but I could if you continue to have trouble.

Yep, permissions here are correct for the duplicatii user : “allow, read & write”. My target folder is (for now) a top-level shared folder, so I set the user-permissions explicitly at creation time.

Ok hmm, not sure what’s going on. Do you have anything like a reverse proxy in the mix?

Not consciously - I wouldn’t even know how to set up one :blush:
I also tried with another user and got the same message.
Is there maybe another way of trying to access the NAS from Windows commandline trying exactly this WebDAV port?

You could try going to http://nas-ip:5005 from a web browser. On mine when I do that the WebDAV service responds with:

Not Found

The requested URL was not found on this server.

Which is the expected response for this test.