Configure outlook notification

Hi,

I’m trying to setup the e-mail notifications for my duplicati back-ups, but i can’t get it done…
To send the e-mail notifications i am using an outlook e-mailaccount and i’m also sending to the same account, using the settings i’ve got from the outlook website.

Could someone help me?

The settings are:
–send-mail-any-operation=true
–send-mail-url=smtp://smtp-mail.outlook.com:587/?starttls=always
–send-mail-username=@outlook.com
–send-mail-password=
–send-mail-to=<receipent@outlook.com
–send-mail-subject=Duplicati %OPERATIONNAME% report for %backup-name%
–send-mail-body=%RESULT%
–send-mail-from=@outlook.com

What am i doing wrong?

Thanks in advance!

Nobody with the same problem? Or someone who knows the solution?

Hi @rikvdelzen, welcome to the forum!

Assuming you removed the --send-mail-password password for security reasons (well done!) but actually use one in your job AND that the forum ate your --send-mail-to and --send-mail-from formatting, I’m not seeing anything wrong.

I would suggest you try adding the --verbose=true parameter and running the send-mail command line option in the GUI or export your job “As command-line” and run it in an actual command line window.

This should provide additional detail about any errors that might be related to the email send step.

Hi @JonMikelV, thanks for your response!

I tried it in command line, but sending mail still failed :frowning:
See:

Still nobody who has a solution for this?

I think you are using a wrong format to add the options. The ignore messages mention three dashes, which is not correct. How did you add the options?

As mentioned in the topicstart:
–send-mail-any-operation=true
–send-mail-url=smtp://smtp-mail.outlook.com:587/?starttls=always
–send-mail-username=@outlook.com
–send-mail-password=
–send-mail-to=<receipent@outlook.com
–send-mail-subject=Duplicati %OPERATIONNAME% report for %backup-name%
–send-mail-body=%RESULT%
–send-mail-from=@outlook.com

I think you are using the wrong dashes. Try to replace (delete) the dash with 2 newly tyoed dashes. Did you copy paste the options from somewhere or did you add them via the gui?

1 Like

I copied them from somewhere on the internet. I will try to add newly typed dashes when I’m home from work. Thanks for your responses :slight_smile:

This isn’t the solution :frowning: . It still doesn’t work…

Please post the complete command.

See:


&

1 Like

Something similar seems to be working for me…
I’m using an office365 business account (with a custom domain). And providing the same email address for all 3 of send-mail-username, send-mail-to & send-mail-from. (Backup destination is to the same OneDrive business account)
I configured it using the Web UI Advanced Options, just as you show last.
I’m using the latest Experimental version “Duplicati - 2.0.3.1_experimental_2018-03-16”.
For office365, I believe the SMTP server should actually be smtp.office365.com, rather than smtp-mail.outlook.com - but either works for me.
When my job completes, under “Show Log”, “Live”, Profiling, I see a “Whole SMTP communication” message that has all sorts of detail about the interaction with the SMTP server. Does your get that far?

1 Like

I don’t see any SMTP connection information or something like that… It’s a bit a mess in the profiling view :joy:

But since today, i get this message at the end of the back-up. I didn’t get it until today, but when i click on “tonen” (it’s like “view” & afwijzen is “deny/ignore”), it doesn’t show any warning.

I’m not using an Office 365 business account, it is a normal outlook.com account, so i’ll have to use the outlook SMTP server.

I tried to test sending an email from command line, but it also doesn’t work.

It looks like something in the RemoteCertificate, but i get this error message when using outlook and gmail, both are getting the same error…

Using the command: --accept-sepcified-ssl-hash=2282CA3D76A4B0FD892162A2E48BFA000FD1D4C6 in the default settings, still doesn’t work. When using it in command line, it also doesn’t work…

Hello, for test try --accept-any-ssl-certificate
I also encounter situation that --accept-sepcified-ssl-hash does not work for email server

I looked at the exact command, and saw that i’ve made a mistake. I typed: “–accept-sepcified-ssl-hash=” but it should be: “–accept-specified-ssl-hash=”. When i use this in the command line, it sends an email from "no-reply@outlook.com", but when i use it in the back-up settings, it won’t send anything after a back-up.

Do you have any idea why?

There is a strange thing in the whole problem: When i send it from command line, without a username and password, it sends an e-mail. But when adding a username and password, it won’t… Without password i can still choose a “send mail from”, and this also works. But only from command line. Within the back-up it doesn’t work.

@rikvdelzen
Did you use –accept-specified-ssl-hash= in backup config?
Specifying this in global Duplicati config does not work

I changed it to the settings in the backup, but this also doesn’t work… With and without username & password…

{“ClassName”:“MailKit.ServiceNotAuthenticatedException”,“Message”:“5.7.57 SMTP; Client was not authenticated to send anonymous mail during MAIL FROM [AM5PR0601CA0037.eurprd06.prod.outlook.com]”,“Data”:null,“InnerException”:null,“HelpURL”:null,“StackTraceString”:"

It doesn’t make any difference when adding username and password

How about trying sending through another account/server/service?
Perhaps the issue is happening with this specific one you’re using…