Compare Feature Not Working

Hello everyone,

I am running Duplicati on Ubuntu 22.04 LTS and I appear to be having an issue with the compare function. I have a backup with 12 versions and when I run the compare command by using


I receive this output:

Listing changes
0: 08/02/2022 14:05:00
10: 08/02/2022 04:00:00

Size of backup 0: 0 bytes

No changes found
Size of backup 10: 0 bytes
Return code: 0

This does not make sense as there are changes between these backups. In addition it says the backups are 0 bytes which is not true. How can I resolve this so I may compare versions? I tried switching the 0 and 10 to see if that would make a difference and it did not.

Welcome to the forums Rob_Roberts.

0 bytes is a bit of an ominous number of bytes to have or rather not have. A few questions off the top.

-Are you running the compare function in the GUI or via mono Duplicati.CommandLine.exe compare in a terminal?

-If you’re using the GUI does the job list show that you’ve backed up more than 0 bytes? The image below shows the details from my Sunday job showing the source data size along with the size of the backup and the amount of versions.

-Can you do a test restore from that backup set?

-Has the backup has been completing without errors (or warnings)?

  1. I am using the web GUI command line.

  2. The GUI shows the following:

84.24 GB

69.09 GB / 18 Versions (Now 18 versions but when I wrote the original post it was 12.)

  1. I was able to do a successful test restore.
  2. No errors or warnings in the log.

Just to verify, when running the Commandline… you’re changing the dropdown to compare, removing anything in the Commandline arguments box then adding 0 10 --full-result each on it’s own line, leaving any advanced options as is they are then clicking on the Run "compare" command now button?

What if you run a compare with no Commandline arguments at all?

My other thought, it could be a Linux issue. I don’t have a 22.04 box kicking around at the moment but I do need a LAMP server for another job so I’ll try to get a few tests in while I’m working on that.

That is correct. I am going to the commandline GUI menu for the backup in question (the only backup I have configured), using the compare dropdown option, removing the existing text from the command line arguments, adding the input exactly as I pasted in the original post, not touching anything else and pressing the run compare button at the bottom.

The output of leaving the command line argument box empty and running compare is:


Listing changes
  1: 08/03/2022 14:05:00
  0: 08/03/2022 15:05:00

Size of backup 1: 0 bytes

No changes found
Size of backup 0: 0 bytes
Return code: 0

Got root?
Is Duplicati running as a service?

Also what’s changing? Any files being created/deleted, path changes or just modifications to an existing file data?

Duplicati is running as a service with root access. However please note the web GUI is firewalled to only be accessible from my IP.

If I add or delete a file to a folder being backed up, run a force backup and then compare the version 0 and 1 it will still show no difference when running the compare command. The file will still restore without any issue though so it does not appear to be an issue with the actual backup.

I also wanted to provide extra information about my setup. I am using an ARM based system and my backup has a custom prefix of “M”.

As a long shot, The COMPARE command says it understands --exclude. Try un-checking any.

I don’t know if any other options might interfere. You could test a simple-as-possible test backup.

I ran several test backups to try to narrow a specific cause to this issue. I have discovered it seems to happen when I have an excluded folder inside of a folder marked for backup. You can view my test backup config, with my Google Drive token removed, here: Duplicati Config -