Change Backup temp location

#1

Hello, I am trying to backup a large amount of data to one drive, but my system volume is filling up crashing duplicati and my computer. Is there a way to change this to somewhere on my data volume e.g. d:\duplicati_temp? Thank you!

#2

You can use the option --tempdir=<path> to specify a temporary folder that is used by Duplicati. If you also want e.g. SQlite (one of Duplicati’s components) to use another temporary folder, you might want to set environment variables TMPDIR or TEMPDIR.

2 Likes
Device mount detection (USB or otherwise)
#3

Thank you for the feedback, when you say use the option --tempdir= I assume you mean create the backup job via cli? ok by me, gotta check it out. Or is this in a config file? The environmental variable may not work as right now the temp data is writing to my profile where the OS Variable is set to %SystemRoot%\TEMP. My data is filling up my C:\Users\user\AppData\Local\Temp directory.

Can i just edit the SQlite config to point elsewhere is that what you mean? I’ll check that out.

Thanks!

#4

I think I found it under my backup Advanced > Commandline …

I added --tempdir=D:\WhereIWantedToBackup

Hope that works.

Thanks!

#6

That worked! Thanks!

#7

This didn’t work, it eventually filled my C:\

#8

What files did it fill with? (I mean the file names)

#9

C:\Users\user\AppData\Local\Temp\dup-415e11e5-c457-4198-9778-6ddf9d8859fc

1 Like
#10

Ok, that is the files generated by Duplicati. No idea why it does not honor the --tempdir setting.

1 Like
#11

If you use the Advanced->CommandLine option, it only uses that switch for that specific run when you push “Run Backup command now” at the very bottom. To change the job permanently, you want to go to your backup Configuration->Edit… then go to the last page, Options. Expand Advanced Options at the bottom, select the drop down “Add advanced option” and look for or type out “tempdir” under the “Core Options” heading. Put the temp path you want in this field and Save. That job should now always use the tempdir location for all future runs of that job.

4 Likes
#12

Thanks for taking the time to write up these detailed instructions. :+1:

I just wanted to let you know that it is extremely easy on this forum to paste images into your post. Just copy and paste as if it were text. So if you have a possibility to take screenshots, those could make it easier to describe which buttons to press. :star_struck:

#13

I’m loving the option of using a Ram Disk for my temp directory. I’m new to the concept but it seems to work great. Still just a day in so I need to test some more.

I have an SSD in my computer so it’s supposed to save on the wear to the drive.

Restore from local disk disable temp folder?
#14

I’ll try this, Thanks!

#15

Did @TPSmono’s post end up working out for you? If not, please let us know as I believe there’s some more development going on around creating temp “files” in memory if the system running Duplicati has enough memory available. (So potentially no need for the extra --tempdir parameter or ram drive setup.)

If so, please consider clicking the image icon on his post to let others know that’s what worked for you.

#16

Following this thread as it seems I have exactly the same issue.

Even when I’ve changed the Configuration > Edit > Advanced Options > Core Options > “tempdir” to the path I want it to use, I get the file dup-25f7d536-927f-453b-8392-4f57b81a5c5b in C:\Users\Trevor\Appdata\Local\Temp

#17

Sorry for the late response. Yes this resolved my issue. Thank you.

1 Like
#18

Did you also try setting the TMPDIR or TEMPDIR environment variable as mentioned in this post?

#19

Good point. I set them to be on another drive years ago but I’ve just had a look and it seems both variables have been set back to their default. Probably a helpful Windows Update “feature”. I’ll see how I get on tomorrow when the backup job runs again.

BTW in Windows 7 those variables are TMP and TEMP

Thanks again.

#20

I got to be honest I don’t remember, this is a while ago I do know that the solution worked by itself, I haven’t used this in a while. Sorry I’m no further help.