Can't delete configuration


On Duplicati on ArchLinux I try to delete a backup configuration, configuration -> delete -> local database is checked -> Delete Backup -> Yes. Nothing happens.

I also tried to restart the server afterwards, but the config is still there. The log file also show nothing, even the Live Logging set to Profiling doesn’t print a single line.

Duplicati is launched as the logged in user.


Did you ever run a backup with this configuration? The local database is created when starting the first backup.
I’m not sure, but IIRC the configuration of a backup job without a local DB can only be deleted with “Delete local DB” unchecked.
If a local DB actually exist, it can be deleted by just deleting the .SQLITE file from the file system.

Hello again Horus!

Does your experience seem to match up with this one?

I was able to duplicate your described scenario by creating a backup job, running it, pausing Duplicati, then trying to delete the job… Note that after actually clicking the
“Yes, delete backup” button my status bar changed to “Next Task: Test Delete Me” (the name of my backup was “Test Delete Me”)

Hi Again!

Yes, I got it worked out. It seems that the deletion is put into the queue, which was currently blocked with another job. As soon as I forced to halt the running job and resumed the server, the deletion was executed.

Still, I think that this needs to be communicated better in the GUI.


Agree! I have run into this a number of times when testing things myself :slight_smile:

As seen above, if there’s something currently running then “manual” commands (such as deletes, Command line, etc.) get queued up behind the currently running command. When that happens perhaps the GUI should show something like “something is already running so this task has been added to the queue”.

But what happens if a task is currently running and a 2nd (scheduled) task is already in the queue. Am I correct in ASSUMING that the 3rd “manual” task gets added 3rd in the queue and does NOT take precedence over the scheduled task (advancing it to 2nd in the queue)?

Yes, there is no queue priority, whatever you ask gets appended to the back of the queue.

1 Like