Unable to delete backup job

I am trialing Dulicati ( and just installed it (Win 7 x64) along with Minio running on a separate Win 7 x64 computer on my LAN.

I setup my first backup job called “Test” with a source of only one folder containing one file. It worked perfectly. I wanted to delete that backup job along with the files in the Minio bucket so I selected the dropdown next to the backup job:

Then under"configuration" I selected “Delete”:

I selected “Delete remote files” and clicked the “Delete backup” button:

I answered the captcha and selected the OK button. It then takes me back to the Home screen, but it is still showing the Test backup job, exactly the same as in the first screenshot above and the files are still present in the Mino bucket.

Is there something I am missing or is this unexpected behavior?

1 Like

I’d say that’s unexpected behavior. Please note that it can take a while for the destination files to be deleted - my test backup had 36 files and it still took about 90 seconds before the GUI showed the backup job gone.

Did you try manually refreshing the web GUI? There might be something cached…

Oh, and be careful with the “delete remote files” feature of version - I believe there’s a bug in it where ALL files (but not sub folders) in the destination get deleted, not just the ones related to the backup job. (Found that one out the hard way with a test backup to D:\ - thank-you undelete tools!)

I did force a refresh of the GUI but the problem persists. Thanks about the warning regarding deleting remote files, I will keep an eye on that.

I think I figured it out. I had the job paused and as soon as I ran the job again it deleted the job and files.

Heh - yep, I think that would do it since pausing isn’t job specific, I believe the whole “server” part of Duplicati (where stuff is actually done) is paused.

If it doesn’t happen to you again may I suggest clicking the checkbox on your “figured it out” post to mark it as the solution? :slight_smile: