Cannot start Duplicati - "Error: UsageReporter failed"

Hello, I just installed Duplicati for Windows ( and cannot start it. I used default options while installation. Once it was intalled system launched Duplicati.GUI.TrayIcon.exe (it is running now) and then opened a browser window in Chrome (http://localhost:8200/ngax/index.html), but this page returns http error 400. I can see the index.html file in c:\Program Files\Duplicati 2\webroot\ngax\ folder. Seems like the web server is not running or configured incorrectly. I executed netstat to make sure port is not taken by any other application:

PID 16308 is a Duplicati process.

Could you help me to understand what is wrong and how to make it work.

Thank you

Hello @keymatic, welcome to the forum!

Sorry to hear you’re having problems getting Duplicati started. Are you able to exit the currently running tray icon then try starting it again from a command line window? That might let you see any errors that might be generated at startup.

If that doesn’t cause show any issues, you could try adding the --log-file=<path> and --log-level=profiling parameters to the command line. That will cause a detailed log to be written to <path> which could make things easier to read through.

Thank you for help, @JonMikelV

Restarting Duplicati.GUI.TrayIcon.exe does not change anything. Icon in the tray is still red (seems like red indicates something is wrong) and page returns http error 400. I restarted the exe file with log params you suggested and here is the output:

2018-02-08 17:49:00Z - Information: Server has started and is listening on, port 8200
2018-02-08 17:49:00Z - Information: Server has started and is listening on, port 8200
2018-02-08 17:49:20Z - Error: UsageReporter failed
System.Net.WebException: The remote server returned an error: (500) Internal Server Error.
в Duplicati.Library.Utility.AsyncHttpRequest.AsyncWrapper.GetResponseOrStream()
в Duplicati.Library.Utility.AsyncHttpRequest.GetResponse()
в Duplicati.Library.UsageReporter.ReportSetUploader.<>c.<b__2_0>d.MoveNext()

Error repeats about 10 times, I pasted here only first of them, they are all the same.

is there any param which I can use to change port number?

This error has been popping up a lot lately, I’m not sure why. Unfortunately, I only know how to disable it from within the GUI - perhaps @kenkendk knows a command line parameter that can do it.

I’m not sure why you want to change the port, but if using the server (not the tray-icon) you can use the --webservice-port=#### parameter.

I have the same error. Any news on what causes it and how to fix it? Thanks!

Hi @rdeschipper, welcome to the forum!

By “the same error” do you mean the UsageReporter failed message?

If so, it’s likely been fixed in

If you don’t want to/can’t update I believe you can manually delete the dupl-usagereport-*files from your temp folder (there will probably be more than 50 of them).

Just tried that, complete re-install, no luck.
Will check some more for detailed errors.

Did you try using the --log-file parameter to capture what’s going on?

Yes I tried this but not much useful information.
In the end, I received a message saying the DB version too high for the Duplicati version I was using (I had tried to downgrade to an earlier version).
Uninstalling and re-installing did not help, not even after a manual clean of system files and registry.

Fortunately I had stored an old version of Duplicati on a separate disk, and that one started like a charm. So I did a brute file copy to the standard location of Duplicati, and from then on Duplicati started again without issues. I had to recreate my backup job though, because the old one got corrupted and there was no way to retrieve it or to restore the DB.

So it remains a mystery what went wrong and why.
At least, I have a running backup system again.

I’m glad you got things running but it’s too bad you had to restort to such measures. :frowning:

I’ve seen a few other “databse version” errors reported lately so it sounds like there might be a growing pain involved with changing particular Dupicati versions. If the DB version issue comes back for you please see if there are any other tickets about it and chime in or go ahead and start your own. Hopefully with enough reports we can narrow down some commonalities to find a specific cause.

For reference, here’s another one: