Backup start time changed when switching to summer time

#1

I noted that the scheduled backup start time switched when going from winter to summer time last weekend (2.0.4.15). It was scheduled 22:00 CET during winter time and then automatically went to 23:00 CET summer time. The system (debian buster) was set up correctly and the time switched as expected.
No big issue, I just manually adapted the schedule (back to 22:00 CET) in duplicati.
I just wanted to let you know, so maybe it does not happen again when switching back to winter time. If this is not a bug and I can do anything please let me know. Thank you very much!

#2

Confirmation, same anomaly on Win10.

#3

Hi @duplicati_fan, welcome to the forum!

Thanks for reporting what happened on your Debian system (and thanks @Folgore101 for continuing in Windows 10).

This is a known issue (Daylight Saving "changes" backup time) related to Duplicati storing time in UTC.

It’s mostly just an annoyance unless your backups are scheduled for specific days near midnight. For example, if you have a backup scheduled for 11:45PM on Sundays then this bug could cause the backup to be skipped because a DST change could cause the trigger time to happen on Monday morning.

I thought a fix was being looked at, but apparently it hasn’t progressed to completion. :frowning:

#4

At least the bug which could break backups might be fixed in canary. I hope there’s a beta before then…

“List of backup timestamps contains duplicates” due to DST change

Recovery from above was also really painful (e.g. patch code, or edit database). A better fix was below:

List of backup timestamps contains duplicates #2857
Possible fix for #2857

Use local time when checking if day is allowed #3528 is a fix in canary for a day-of-week checkbox bug.

The time shift when time type changes is unfixed. Some rather large-sounding work has been proposed, however I’m kind of hoping there’s a rather simple (so less risky) answer, as there was for both others…