Backup results in access denied error


#1

Hello,
my backup has a warning because of one file in the Firefox profile. I have 2 questions.

  1. Why is ParsedResult: Error in my report although there is only a warning. I use www.duplicati-monitoring.com and I always get thre reports marked as error. I think it should only be Warning.

2 Why do I get the error with this file? Duplicati runs as service and uses snapshots. So all files should be accessible.

I use Duplicati - 2.0.2.13_canary_2017-11-22 on Windows 10

Here is the report:

DeletedFiles: 252
DeletedFolders: 0
ModifiedFiles: 542
ExaminedFiles: 804982
OpenedFiles: 2905
AddedFiles: 2303
SizeOfModifiedFiles: 22864272258
SizeOfAddedFiles: 65632281
SizeOfExaminedFiles: 375270559972
SizeOfOpenedFiles: 22934019950
NotProcessedFiles: 0
AddedFolders: 2
TooLargeFiles: 0
FilesWithError: 1
ModifiedFolders: 0
ModifiedSymlinks: 0
AddedSymlinks: 0
DeletedSymlinks: 0
PartialBackup: False
Dryrun: False
MainOperation: Backup
CompactResults: null
DeleteResults:
   DeletedSets: []
   Dryrun: False
   MainOperation: Delete
   CompactResults: null
   ParsedResult: Success
   EndTime: 04.12.2017 14:57:36 (1512395856)
   BeginTime: 04.12.2017 14:56:52 (1512395812)
   Duration: 00:00:44.5164979
   BackendStatistics:
       RemoteCalls: 10
       BytesUploaded: 322940113
       BytesDownloaded: 171231927
       FilesUploaded: 5
       FilesDownloaded: 3
       FilesDeleted: 0
       FoldersCreated: 0
       RetryAttempts: 0
       UnknownFileSize: 0
       UnknownFileCount: 0
       KnownFileCount: 247
       KnownFileSize: 281834053811
       LastBackupDate: 04.12.2017 14:39:41 (1512394781)
       BackupListCount: 11
       TotalQuotaSpace: 0
       FreeQuotaSpace: 0
       AssignedQuotaSpace: -1
       ParsedResult: Success
RepairResults: null
TestResults:
   MainOperation: Test
   Verifications: [
       Key: duplicati-20171204T110000Z.dlist.zip.aes
       Value: [],
       Key: duplicati-id6f0878c922148d685b18f7be074c651.dindex.zip.aes
       Value: [],
       Key: duplicati-b86107ef265bf4600bd62c85ae2eb59e6.dblock.zip.aes
       Value: []
   ]
   ParsedResult: Success
   EndTime: 04.12.2017 14:57:43 (1512395863)
   BeginTime: 04.12.2017 14:57:37 (1512395857)
   Duration: 00:00:05.4834672
ParsedResult: Error
EndTime: 04.12.2017 14:57:43 (1512395863)
BeginTime: 04.12.2017 14:39:41 (1512394781)
Duration: 00:18:02.2263007
Messages: [
   No remote filesets were deleted
]
Warnings: [
   Failed to process metadata for "C:\Daten\System\Firefox\Profiles\Jascha\cert8.dir\bx-POkXwcVopUOtD7K+FcKX85GHk=", storing empty metadata => (5) Zugriff verweigert: [\\?\GLOBALROOT\Device\HarddiskVolumeShadowCopy5\Daten\System\Firefox\Profiles\Jascha\cert8.dir\bx-POkXwcVopUOtD7K+FcKX85GHk=],
   Failed to process path: C:\Daten\System\Firefox\Profiles\Jascha\cert8.dir\bx-POkXwcVopUOtD7K+FcKX85GHk= => (5) Zugriff verweigert: [\\?\GLOBALROOT\Device\HarddiskVolumeShadowCopy5\Daten\System\Firefox\Profiles\Jascha\cert8.dir\bx-POkXwcVopUOtD7K+FcKX85GHk=]
]
Errors: []

Thank You


#2

Generally the “storing empty metadata” and “Failed to process path” seem to come together and seem to be caused by a permissions issue rather than an in-use situation. So in this case I doubt snapshots has anything to do with the problem.

My first guess is it’s related to these possibly being temp files that Firefox is locking down permissions wise for general system security reasons.

What version of Firefox are you using?


#3

I am using Firefox Version 57.0.1


#4

I’m running that as well (64 bit on Windows 10) so I set up a test backup of just my Mozilla folders.

With Firefox running and no snapshot settings or --snapshot-policy set to Off I get " Failed to process path" errors, but no “Storing empty metadata” messages.

With --snapshot-policy set to Required, On, or Auto I get no errors at all. If you verify your --snapshot-policy is Required, On, or Auto then I’m pretty sure it’s a permissions issue.

Note that it looks like the folder structure you’re using isn’t the normal Windows one I’m used to where Firefox is a subfolder of a Mozilla folder. Are you using a custom version of FF in some way?


#5

--snapshot-policy is set to on.
No custom FF version but I changed the path for my profile.

I tried it with a Testbackup only the FF profile and get the same error.

I get a message for the error looking like this:


Failed to process path: C:\Daten\System\Firefox\Profiles\Jascha\cert8.dir\bx-POkXwcVopUOtD7K+FcKX85GHk=
System.UnauthorizedAccessException: (5) Zugriff verweigert: [\?\GLOBALROOT\Device\HarddiskVolumeShadowCopy2\Daten\System\Firefox\Profiles\Jascha\cert8.dir\bx-POkXwcVopUOtD7K+FcKX85GHk=]
bei Alphaleonis.Win32.NativeError.ThrowException(UInt32 errorCode, String readPath, String writePath)
bei Alphaleonis.Win32.Filesystem.File.CreateFileCore(KernelTransaction transaction, String path, ExtendedFileAttributes attributes, FileSecurity fileSecurity, FileMode fileMode, FileSystemRights fileSystemRights, FileShare fileShare, Boolean checkPath, PathFormat pathFormat)
bei Alphaleonis.Win32.Filesystem.File.OpenCore(KernelTransaction transaction, String path, FileMode mode, FileSystemRights rights, FileShare share, ExtendedFileAttributes attributes, Nullable`1 bufferSize, FileSecurity security, PathFormat pathFormat)
bei Duplicati.Library.Snapshots.SystemIOWindows.FileOpenRead(String path)
bei Duplicati.Library.Snapshots.WindowsSnapshot.OpenRead(String file)
bei Duplicati.Library.Main.Operation.BackupHandler.HandleFilesystemEntry(ISnapshotService snapshot, BackendManager backend, String path, FileAttributes attributes)


#6

It appears that the snapshot is in place (the \?\GLOBALROOT\... stuff), but still permission is denied.

I don’t know why this happens, but I think it is a general VSS issue. Googling the problem did not reveal anything, but maybe I hit the wrong keywords…


#7

What is with my other point?
Why does this one file cause the global result in error and not in warning?


#8

I guess it is a matter of preference when things are considered a warning and when it should be considered an error. When you have any files that caused errors, as indicated with FilesWithError: 1, then the status is reported as Error. But i agree that it does not make sense since the message is logged as a warning. We should go either one or the other.