--auth-password is not supported

I am getting the following warning only when backing up to the cloud (we use One Drive).

[Warning-Duplicati.Library.Main.Controller-UnsupportedOption]: The supplied option --auth-password is not supported and will be ignored

I don’t get that warning when backing up to a local device. Duplicati is running on our QNAP NAS.

Anyone have a solution to this?



1 Like

Hello @quinting and welcome to the forum!

Do you recall having every typed a password for OneDrive? Do you see anything like that now?

OneDrive is confusing because it has so many variations. Is yours Personal or “for Business”?

Make sure you configured Duplicati with the right storage type for your specific storage provider.
For OneDrive Personal, you probably want Microsoft OneDrive v2 which lacks --auth-password.

Sometimes changing types can leave leftovers from other types. You can try Advanced options on screen 5 for Options to see if you see that one. Another way to see options is to look at Commandline for that job.

OK, I see in the command line options, that &auth-password=XXXXXX is at the end of the “target url”. Can I just delete that, and save it, and auth-password won’t be used anymore?



Commandline configuration doesn’t persist. You can certainly do a backup run to see if it succeeds, but eventually you’ll have to get the job fixed. Did you look to see if that option was also in the advanced options? Sometimes options can get in places that are hard to get to, but first let’s see if they’re in any easier place…

If regular Advanced options doesn’t show it then let you remove it, try the three-dot menu to Edit as text.

Hmmm, don’t see a save option on that page, so I guess you can’t edit in there. I looked on the Options tab for the job, and that option does not appear in the list…



Below are Advanced options on screen 5 for Options, the three-dot menu, the Edit as text, and the Save:


Edit as text shows a blank box. There is nothing in there.

Screenshot attached.

And as a note, I have created a new cloud back up, ensuring that I pic One Drive V2 and not Business, and I get the same warning.

By the way, I don’t know if Duplicati wrote their own forum interface, or if using a third party product, but it is probably the best forum interface I have seen. :smile:


I figured it out! You might want to add this to your KB, or manual or something. It seems that if you use Google Password Manager to save your login password for Duplicati, it will automatically enter it in the auth-password field (even though that field doesn’t exist on the screen).

I looked at the command line again, and realized that the password that it was displaying was my Duplicati password…so I cleared the password manager, and created a new cloud backup job, and now it works!

Thanks for your help.


Just in case, like me, you are looking here because you have warnings like:

The supplied option --auth-username is not supported and will be ignored
The supplied option --auth-password is not supported and will be ignored

Initially I configured my backup job to use OneDrive for Business, but then could not do any operations afterwards due to limits for OneDrive for Business. I reconfigured the job to use OneDrivev2 which fixed my issues, but then got the errors above.

This happens, as @ts678 suggests above, because “changing types can leave leftovers…”. To clean things up, edit the configuration of the job then choose your previous type (in my case OneDrive for Business), remove the data (username and password) then switch back to your new type before clicking Next through the screens then click Save. If you check the Commandline before and after you should see the extraneous options disappear.


It is called “Discourse” and just works beautifully:

1 Like

I solved it using the GUI interface. Had that error on all backups, although the job was done with success.

Go to the job configuration, second step “Destination”. I am using OneDriveV2 as a backup destination.

There you have the three dots menu.

Just use “Copy destination URL to clipboard”, edit it to remove the &auth-password=XXXX, copy it and use the “Import destination URL” to paste it.

It beats having to delete the job and rebuild it…



That’s frickin’ excellent. Thanks for posting this - it solved the same issue for me just now.


It’s possibly a two-step process, which Firefox “Autofill logins and Passwords” can also do damage on.

  1. Password saver may autofill too many places, getting --auth-password is not supported #4102 (anybody out there expert on unconfusing several overly-eager-to-autofill password managers?)

  2. Changing backend type leaves invalid backend options #3082
    (which could happen without step 1, and whose fix would prevent step 1 from getting into step 2)

1 Like

I was in the same situation, had a previous One DriveBusiness destination configured and supplied options where kept when I changed to OneDrive v2. Jaytee solution solved my issue

1 Like

it worked for me too!
thanks dude!

Fiermont’s solution works perfectly! Thanks!

This absolutely works! I added localhost to LastPass URL rules including host and port matching to prevent the error in the future. Seems like the assumption being made by Duplicati warrants a bug report?

1 Like