All OneDrive backups failed

I have multiple servers, each backing up using OneDrivev2

Last night all failed with an Oauth error. The concern is that each server uses a different Onedrive account. I have tried getting a new AuthID token which is successful but when I click ‘test’ it fails:-

Failed to connect: Failed to authorize using the OAuth service: Server error. If the problem persists, try generating a new authid token from: Duplicati OAuth Handler

Any ideas what I can look at next?

I am using on all servers.

Same here.

I updated docker containers yesterday. So I first thought it was related to that.
But now I see your post.

Same here. All my nightly backups failed.

Same here too. I am using Duplicati version

Note: Re-generated the OAuthauthetication token, but it does not make any difference.

Ditto. Getting the OAuth failure for
Regenerated authid and still no go. 500 server error showing. login via web is fine, and shows files - so looks like something has gone bang in the middleware oauth handler :\

Same problem here… All my backups to OneDrive failed and regenerating the token has no effect.

Here too, on different servers, I only noticed error in OneDrive.
Generates the key but does not authenticate.

This isn’t just OneDrive - it seems to be all providers using OAuth
I’ve put a main thread here to try to consolidate :

I use Dropbox and OneDrive. Dropbox is working fine, and OneDrive… Well, we know we are having issues :wink:

Same Error. It seems a general failure with OAuth

If you create a new task, you receive the AuthID fine, but later, it does not work :smiling_face_with_tear:

This issue has been resolved. Details at OAuth Issues affecting multiple storage providers - #15 by kenkendk

Thank you.! I can confirm that all my backups were successful last night.

Good job! :smiley: