Debian 10

Scheduled backups only work if a web browser is running. How can I make scheduled backups work with a closed browser?

That doesn’t sound right. The backup engine runs regardless if a web browser is displaying information from it or not.

How did you install on Debian? Are you using systemd to start the backup engine on system boot? What is shown if you run sudo systemctl status duplicati ?

$ sudo systemctl status duplicati
● duplicati.service - Duplicati web-server
Loaded: loaded (/lib/systemd/system/duplicati.service; disabled; vendor preset: enabled)
Active: inactive (dead)

That just shows that Duplicati is running in user mode, not as a service. I get exactly the same result, because I am also only running it in user mode, which is the default mode.

How to run as a service?

Do you need to run it as service? As drwtsn32 said, Duplicati runs the scheduled backups regardless if a web browser is displaying information from it or not.

If you have a real reason to run it as service (in which case it runs as root instead your own account), see documentation, and look up information from this forum. Since I am using duplicati in user mode, I have not collected links to the threads where advanced advice is given. Anyway, the relevant manual page is Other Command Line Utilities - Duplicati 2 User's Manual. It does not mention systemcl or systemd though; that side of the story you need to dig up from the forum.

On my Debian system I wanted it to run as a service. (It’s a server, not a user workstation.) I installed it as root and it registered with systemd automatically. I then configured systemd to launch it at startup:

$ sudo systemctl enable duplicati

Found the instructions, finally: Installing Duplicati on Linux (Ubuntu / LinuxLite)

It really should be moved to the manual.