Working NAS folder suddenly not accessible - Duplicati thinks it does not exist

Boy, I feel a bit dumb that I cannot figure this out but I am stumped.

I have been running Duplicati on two Win 10 computers for at least a year, doing regular backups throughout the day to a local open media vault NAS folder and a Backblaze B2 cloud folder. Suddenly (a few days ago) one of the systems is throwing an error about the local folder: “The folder \OMV-NAS\backups/myfolder does not exist. Create it now?”

Nothing has changed on this system and as notes, it’s been backing up for a year or so to this destination.
Backups to the B2 cloud are still working.
User and password is correct.
I can mount the drive manually in Windows Explorer so the system can access it.
The other system is working normally so nothing would seem wrong on the NAS side.

The system with the NAS folder issue is still on
The system that is working is running

Any ideas ?

Any similarity to this thread: SMB file shares not connecting - Duplicati as Service

What does “Test connection” say when you edit the destination of the job?

If you are running Duplicati as a service And just updated to Win 10 2004, this could be the issue: SMB file shares not connecting - Duplicati as Service

Any similarity to this thread

Exactly! Just goes to show that I have not been following the forum of late.
Indeed, the machine with the issue is on Win 10 2004 while the one that is working is on 1903
And as described, “Test connection” says “Folder … does not exist. Create it now?

However… I thought both systems were setup identically but evidently the system that is not working is running Duplicati as a service under the ‘Local system account’ while the system that is working is running the service under the main user account.I know back then, I had issues getting both system up and running as a service so it’s possible this deviation was what worked, or it was changed with the update to Win 10 2004.

I likely cannot really access that system until this evening at which point I will look more carefully at the service settings and likley add these comments to: SMB file shares not connecting - Duplicati as Service

1 Like

Some people on the Internet are reporting this fixable by using an IP address or a hosts file entry.

Odd account issues every reboot since Windows 10 2004 Update

Windows 10 - Mapped Drive Issue - Keep losing connection

Thank you for this suggestion. I tried switching back to the Local System account, restarted the service, then revised the UNC path to \ipaddress\sharename from \hostname\sharename. Unfortunately, the results were the same. Adding the entry in hosts didn’t make a difference in behavior.

I feel a bit bad but at the moment, I cannot devote time to this so I punted and downgraded the system back to 1903.
Happily, everything is working normally but I’m just delaying the inevitable :slight_smile:

Try using hostname\username for the credentials per SMB file shares not connecting - Duplicati as Service. Worked for me.

works also for me! Thanks!