Windows: S3 Failing from one host but not another

First off, I must say I do like Duplicati, it’s a great opensource product!

I’m running into a slight issue however…

I am trying to use Duplicati to backup a Windows Shares server to Amazon S3.
I’ve got Duplicati installed as the system user,
I’ve got the API key set to and tested on my local machine and I know it has rights to do everything it needs to do.

The issue is when I run the routine from the Windows Shares server, it only backs up the parent folder and non of its contents. C:\Shares and nothing below it.

To check this was not a local permissions issue, I ran an SFTP routine backing up C:\Shares and this ran without issue.

  • Windows workstation
    • S3 Backup runs fine, all folders and contents.
  • Windows Server
    • S3 Only backs up parent directory and no contents.
    • SFTP run fine, all folders and contents.

Same API Key used on Workstation as Server…

I was wondering if anyone had any suggestions?

What is inside C:\Shares? Are they normal folders, or are they junction points/symlinks?

There is around 2.71TB of just normal folders, not symlinked or whatever the windows term is for that.

Have you configured any Filters or Exclude options on the “Source Data” section of your backup configuration?

The only Exclude I have included is for Temporary Files,
I have also ran this without any excludes and get the same result.

It does not make sense if I am applying the same rules between the S3 config and the SFTP config, that the SFTP works and sends files and the S3 yields an empty folder.

Yeah that doesn’t make sense… we are missing something. The destination type is not relevant to the source selection.

SFTP is a backup in the same Duplicati (running as SYSTEM) as S3? It sounded like a separate client:

On Windows Server in C:\Shares NTFS filesystem, no mounting of things from elsewhere to build it?

Are you able to manually browse folders under C:\Shares when you go to the Source Data tree view?

I suppose you can look at About → Show log → Live → Verbose for a clue on why backup doesn’t walk.

The lower section on Exclude is file attribute-based. Also check for stray Filters in the top section.

Onto a winner here!

A wild * appeared in there… 3 day! 3 DAYS! trying to figure that out.

Thank you!