Except in whitelist case, the connection may get blocked. That’s the concern.
Presumption is that some IP level blocker needs an IP whitelist, but what IP?
Today’s IP might not be tomorrow’s IP. It likely prefers static IP, but lacks that.
There might be a way to make it static with a custom domain, but I’m unsure.
Here’s what I mean by dynamic (rather than static). IP changes occasionally:
$ dig duplicati-oauth-handler.appspot.com
; <<>> DiG 9.18.30-0ubuntu0.22.04.2-Ubuntu <<>> duplicati-oauth-handler.appspot.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 52846
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1
;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 65494
;; QUESTION SECTION:
;duplicati-oauth-handler.appspot.com. IN A
;; ANSWER SECTION:
duplicati-oauth-handler.appspot.com. 300 IN A 172.253.62.153
$ dig duplicati-oauth-handler.appspot.com
; <<>> DiG 9.18.30-0ubuntu0.22.04.2-Ubuntu <<>> duplicati-oauth-handler.appspot.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 33126
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1
;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 65494
;; QUESTION SECTION:
;duplicati-oauth-handler.appspot.com. IN A
;; ANSWER SECTION:
duplicati-oauth-handler.appspot.com. 227 IN A 142.251.167.153
$ dig duplicati-oauth-handler.appspot.com
; <<>> DiG 9.18.30-0ubuntu0.22.04.2-Ubuntu <<>> duplicati-oauth-handler.appspot.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 7483
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1
;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 65494
;; QUESTION SECTION:
;duplicati-oauth-handler.appspot.com. IN A
;; ANSWER SECTION:
duplicati-oauth-handler.appspot.com. 300 IN A 172.253.62.153
$ dig -x 172.253.62.153
; <<>> DiG 9.18.30-0ubuntu0.22.04.2-Ubuntu <<>> -x 172.253.62.153
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 30787
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1
;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 65494
;; QUESTION SECTION:
;153.62.253.172.in-addr.arpa. IN PTR
;; ANSWER SECTION:
153.62.253.172.in-addr.arpa. 2917 IN PTR bc-in-f153.1e100.net.
(OK, technically it reverses, but not into anything you'd whitelist)
If so, it doesn’t help because this (and most IPs I saw) won’t reverse lookup.
Maybe @roasted_watermelon can get some info on whitelisting dynamic IP?
Or if somehow the current setup works long-term, great, but I’d be puzzled…