When duplicati is launched, the backup is duplicated

The problem is when I press the button "start "
in the web interface, then duplicati starts to make a backup
more than once in a row. It’s a lot of pressure on the system.
Besides, it doesn’t make sense.
In my settings, I should make a backup every 300 minutes.
why is this happening?

Here are the screenshots of several duplicates

Hello, what do you mean by pressing “start”? If you are starting a backup manually, it will do that in addition to running the scheduled backup. (Jobs will be queued up if necessary as it doesn’t run more than one activity at a time.)

So I press this button duplicati starts and immediately makes 4 backup versions.
And I have 3 tasks in task, so it will be 12 times backup and a waste of my time
It’s a terrible idea

Ok, that’s just the “resume” button. I’m guessing you have Duplicati configured to pause for a certain number of minutes on startup.

Duplicati will attempt to do a backup as soon as possible if the backup window is missed (like when your computer is turned off). But it may also queue up one other operation. I’m not sure how you are getting 4 backups in a row.

What version are you using?

I just checked one of my PCs running 2.0.5.1. It has been off for a few days and is configured to back up every 4 hours. After turning it on, Duplicati performed one backup for each of my two backup sets (since their schedules were missed). I am not seeing it run more than one.

Here are my schedule settings

And if I press the Resume button, then first the backup version will start, and after 5-10 minutes again. I don’t see the point in this, since in 10 minutes little will change in my files

What version are you using?

You are currently running Duplicati - 2.0.5.103_canary_2020-02-18

Apparently this meant the pause/resume button. Is button use required in order to get a duplicate?

Apparently this meant 185 minutes. That fits early times well except for some delayed starts maybe because system was sleeping, off, or paused. Below is history using the screenshot of original post:

185 minutes since prior? (Y)es, (N)o, (F)irst of day.

5 F
6 Y
7 Y
8 Y
9 Y
10 N (late)
11 N (late)
12 N (late)
13 Y
14 Y
15 F
16 Y
17 N (late)
18 Y
19 Y
20 F
21 Y
22 Y
23 Y
24 Y
25 F
26

Does system sleep between backups sometimes? I’m assuming that explains some of the late runs.

Timing gets kind of weird after the big gap between April 14 morning and April 16 afternoon. Timing doesn’t line up going either forwards 185 minutes at a time from April 14 or backwards from April 18.

One oddity (maybe a bug) that I was able to reproduce was that if a backup is paused and allowed to miss two run times (one won’t do it), it will run twice in a row when resume is done, buI I can’t get this:

The original post (and subject) shows duplicate (2) runs, which may be wrong. Have an example of 4?
Accurate information on any pauses, resumes, sleeps, restarts, etc. would also help to investigate this.

Mine sleeps at night. It doesn’t do pointless duplicates on wake. My backup test (conveniently set at interval of 10 minutes, starting at an even 10 minute clock time) also behaves, but Pause + Resume duplicates back-to-back on Resume if more than 1 time slot is missed. I think it only did double even paused for more than 2 missed backups, but if you try to reproduce this oddity, feel free to test that…

I wasn’t able to replicate that. I have Duplicati set to pause for 5 minutes when it first launches. I started the machine after it was off for a few days and press the resume button like the OP, but it still only runs one backup even though many were missed (scheduled once every 4 hours).

Maybe Sleep is the key instead of full power off?

Sorry, I just re-read what you wrote. You are saying you can replicate it if you manually pause Duplicati… I may try that.

Yes, system is on the whole time, manual Pause, wait about 12 minutes (to miss two slots), Resume.
To be lazy, and ensure a backup was recorded regardless, I used –upload-unchanged-backups=true.
This was a trivial backup that takes about a second, so I look closely, and then check Restore times.

EDIT:

I used Pause at 7:29, thereby missing 7:30, 7:40, 7:50, 8:00, and 8:10. Resume at 8:11 got two runs:

image

A profiling log doesn’t seem to show Pause and Resume, but here’s the second run right after first run:

2020-04-20 20:11:19 -04 - [Profiling-Timer.Finished-Duplicati.Library.Main.Controller-RunBackup]: Running Backup took 0:00:00:01.387
2020-04-20 20:11:19 -04 - [Information-Duplicati.Library.Main.Controller-CompletedOperation]: The operation Backup has completed
2020-04-20 20:11:20 -04 - [Information-Duplicati.Library.Main.Controller-StartingOperation]: The operation Backup has started
2020-04-20 20:11:20 -04 - [Profiling-Timer.Begin-Duplicati.Library.Main.Controller-RunBackup]: Starting - Running Backup

And so my news I woke up not long ago 9:27 AM
My laptop was in sleep mode, I woke him up, pressed the Resume button
The backup of the system began, the screenshot shows how many times the backup happened.

I wanted after backup Resume button to not have backup

Hello,

I can also confirm this behavior. After waking up from hibernation, my scheduled backup (running every 87 minutes, usually took about 40s to finish its job) runs twice:

21 Apr 2020 13:01 - Operation: Backup
21 Apr 2020 13:01 - Operation: Backup
20 Apr 2020 13:26 - Operation: Backup
20 Apr 2020 13:22 - Operation: Backup
19 Apr 2020 12:56 - Operation: Backup
19 Apr 2020 12:55 - Operation: Backup
18 Apr 2020 12:45 - Operation: Backup
18 Apr 2020 12:44 - Operation: Backup
17 Apr 2020 12:07 - Operation: Backup
17 Apr 2020 12:06 - Operation: Backup

I’m using Duplicati 2.0.5.1 (Windows 10 x64, Home). Also, I’ve set 1 hour “Pause after startup or hibernation” option.

Does setting a shorter pause avoid this, or at least make it less consistent?

My preliminary testing with on-the-10-minute-mark test backup is like what I get with manual Pause.

Setting a 15 minute Pause after startup or hibernation skipped two potential backups while Windows was awake, and running Duplicati in paused mode. Sleep 8:16, wake 8:17, got two 8:32s.

Setting a 5 minute pause, Windows sleep, and Windows wake in time for a single backup slot to be missed resulted in a single backup. This is a somewhat different behavior than the 60 minute pause causing a repeat of the every-87-minutes backup because I don’t see how one could miss two slots.

One interesting possibly relevant (or possibly misleading) thing to watch is what the status bar says about the next backup time. Often I see this jump to the next slot when a slot is missed (even when Duplicati Pause is in effect, but sometimes it’s delayed, e.g. I just had one delay 1:46 after the miss.

For even more fun, look at About --> System info at the bottom where it shows a not-human-friendly

  • proposedSchedule : (which shows the plan for future backups in UTC time, subject to delays)
  • schedulerQueueIds : (which seems to get an entry when the missed backup is finally noticed)
  • pauseTimeRemain : (which seems to be in milliseconds)

This testing was on 2.0.5.104 Canary, but I suspect nobody’s been messing in the scheduler lately…

that’s how i have

Not particularly interesting if critical spot has come and gone. You’re seemingly out of pause, just waiting for next backup at 2:42 PM UTC which would be 5:42 PM (as seen in status bar) if you’re in UTC+3 time.

да у меня есть время на UTC +3
что делать? Какие настройки сделать

Translation from Russian:

Yes, I have time for UTC +3
what to do? What settings do

Still quite unclear. Is there a question about a setting? For what to do, how about a shorter pause?

Although the test results vary (and more will maybe be posted), for me issue requires you allowing Duplicati to be paused on a running (awake) system for over 185 minutes. If that’s it, avoid that. :wink:

You can keep your own notes on when you do things, or for simply figuring out system sleeps, use SleepStudy which is on the PC, or if you use third-party tools, you can install TurnedOnTimesView

Beyond that, if this is a bug, someone will probably have to open a GitHub issue to get it looked at.

дублирование происходит только в двух случаях

  1. после режима сна
  2. после нажатие на кнопку Resume

вот моя пауза

раньше пауза была 10 минут

duplication occurs only in two cases

 after sleep
 after clicking on the Resume button

here is my pause

(picture)

before the pause was 10 minutes

(end translation – and could you please post English if you have an adequate translator available)

So your result is different. Regardless, someone will have to (maybe learn and) look into the code.