Web interface failing after recent Firefox update

Are others using Duplicati with Firefox as default browser on Windows seeing this:

when clicking the system tray icon and selecting Open?

Pasting the same URL (http://localhost:8200/ngax/index.html) into Google Chrome works normally, as did Firefox until two days ago. If memory serves, there was an automatic Firefox update between the last time it worked and the first time it didn’t, so I’m guessing that has something to do with it.

I can’t dismiss the top message box, so I can’t read the ones beneath it.

Yes, I saw this yesterday but after closing Firefox completely and reopening it the problem went away. I haven’t had it happen again since, so wasn’t able to do any further troubleshooting.

Thanks. While that didn’t work for me (I had already closed Firefox multiple times and even rebooted Windows twice before I thought to try Chrome), it gave me an idea, which appears to have worked.

In Firefox, I went to History / Show All History, then right-clicked the Duplicati URL and chose “Forget About This Site.” Several attempts since to access the Duplicati user interface have all succeeded.

I’m not sure if that clears the Firefox caches only for localhost:8200 or for all of localhost. I don’t think there could have been anything other than Duplicati data cached for localhost that I would expect to interfere with Duplicati — and surely nothing at localhost:8200. Seeing the double curly braces makes me think something went wrong with processing a Javascript templating library…

I had this happen again today, and noticed uBlock Origin had a high number of blocked elements. I disabled uBlock Origin for “localhost”, did a refresh, and everything was working again.

Today being Dec 27. I wonder if you had the Dec 26 fix below, which possibly explains localhost issues:


Closed as fixed:

Good find! That looks like the issue. Not sure when the fix will be rolled out to production.

I had this happen. It went away after a bunch of hours (maybe about 6) and Duplicati will work in privacy mode anyway. Some sort of caching issue looks to me and clearing all the cache didn’t fix it but waiting did.

Not being having any further issue with it since waiting it out.

Didn’t look into it further but it may or may not be related to that bug above. Either way, I consider it all fine now.

1 Like