Warning for backup failure of a file which is however excluded

I configured a simple backup for three folder trees, excluding a single sub-branch. After the first run I realized that this comprises also a Outlook.pst file, which can not be backed up while in use.
So I updated the configuration, excluding explicitly this very file.
Still I keep getting warnings that this file could not be backed up.
Why? How do I avoid this? (using

Job config:
“C:\Program Files\Duplicati 2\Duplicati.CommandLine.exe” backup “file://X:\Win10_THINK\Duplicati\D\” “D:\0 Arbeit\” “D:\com\” “D:\users\” --backup-name="(L520)D:\ ohne abgelegte videos, pst und CSC" --dbpath=“C:\Users\user\AppData\Local\Duplicati\xxxxx.sqlite” --encryption-module=aes --compression-module=zip --dblock-size=50mb --passphrase=XXXXX --retention-policy=“1W:1D,4W:1W,12M:1M” --disable-module=console-password-input --exclude=“D:\0 Arbeit\Abgelegt auf NAS\Videos\” --exclude=outlook.pst

Warning message (excerpt):
Warnings: [
2019-12-18 13:11:20 +01 - [Warning-Duplicati.Library.Main.Operation.Backup.FileBlockProcessor.FileEntry-PathProcessingFailed]: Failed to process path: D:\users\user\Documents\Outlook-Dateien\Outlook-Daten.pst

I believe you need at least some path information when using --exclude. Try --exclude=*\outlook.pst and see if it works for you.

Nice try, unfortunately no difference in result. FWIW: I specified the option in the configuration dialog, and there was no indication whatsoever that anything else but the pure filename needs to be specified.
I suspect it has to do with the fact that I specified the exclusion only after I ran at least one backup. I faintly remember that earlier attempts to modify a configuration after some time in use also produced problems. Still I’d prefer to wait with setting up the job from scratch until someone clearly tells me that you can’t modify a job once in use. I’d consider this a serious limitation after all …

The original post has --exclude=outlook.pst and a warning on Outlook-Daten.pst
Personally (and having tested some), I think you need a wildcard AND rest of the name.

Because the web UI editor is a bit crude (has issues, poor help text, etc.), use the three-dot menu and Edit as text to test that it makes the right output, per the syntax imperfectly described under Filters.

The TEST-FILTERS command can help get the syntax right or run experiments without doing backups.

There are very few things that Duplicati won’t let you change at your risk as you like whenever you like.


Note that the value cannot be changed after remote files are created.

Choosing sizes in Duplicati

Due to the way blocks are referenced (by hashes), it is not possible to change the chunk size after the first backup has been made. Duplicati will abort the operation with an error if you attempt to change the chunk size on an existing backup.

The encryption passphrase applies to the whole backup, so change is a pain, but theoretically possible.

Shame on me - you are right. I simply specified the wrong (incomplete) filename. After getting the full filename right, however I had to prefix it with *\ to get rid of the warning. Not a big deal, but it would be good for the UI to give a hint how how to correctly specify the syntax for excluding a file vs. a folder.
Thanks also for the hints with the TEST-FILTERS command and more.