VssObjectNotFoundException Failed to create a snapshot

[Warning-Duplicati.Library.Main.Operation.BackupHandler-SnapshotFailed]: Failed to create a snapshot: Alphaleonis.Win32.Vss.VssObjectNotFoundException: The requested object does not exist

I am recently getting this error. Snapshots have worked before. Not sure what caused it. Maybe it was an automated update of windows?

Tried fixing by installing an available update of duplicati,
Installed vc++ 2015 redist.
Installed latest version downloaded from duplicati website.

The problem is still present. what can i do?

This was discussed recently - look it up using forum search. So far we konw that it seems intermittent and does not seem to cause any real problems. I am not sure if anyone has reported it as a bug yet.

Are you seeing any VSS errors in your Windows Event Viewer?


VSS has a habit of locking up. Have found this with other backup programs with intermittent VSS failures

From an admin cmd prompt do a vssadmin list writers

Check if any are in an error state or not responding. Link below explains better


You can also reboot but do a full restart hold shift-key shutdown as the normal Win10 hyper sleep restart wont fix the writers.

1 Like

36200: Acronis Backup: VSS Troubleshooting Guide has other ideas which might be adaptable…

I’ve had some intermittent VSS errors (not this one) that began after update to Windows 10 1909.
Duplicati version didn’t change. I never figured the error out. I haven’t pursued it heavily though…

Thank you all for your input.

I did find the other post prior to posting, that’s where i got the idea of installing the c++ redist. package.

I don’t see any VSS errors in windows log at the time of the errormessage in duplicati. (not sure what they would look like though)

vssadmin list writers returns all as state: stable, last error: no error. I did a full restart anyway, with no result.

i installed 2015-2019 c++ redist. package from Download Visual Studio 2019 for Windows & Mac other tools and frameworks , did not resolve the problem.

acronis vssdoctor did find a misconfigured vss shadow storage, but fixing that has not resolved the problem.

It does cause files not being backed up: outlook pst files when outlook was open during backup for example.
Every run of the backup has a warning, which is bad, as I get the habbit of ignoring the warnings.

I believe they are in the “Application” section of Event Viewer. Look for events with “VSS” as the source.