"Verify files" stuck on "Starting backup..."

I recently performed a successful backup.

After completing this backup, I clicked on “Verify files”.

(I’ve done this several times before, with success.)

This time, Duplicati has been stuck on “Starting backup…” for several hours after clicking on “Verify files”.

Help please!

Many hours later, no change!

Duplicati still says “Starting backup…”

Can you go to About → Show Log → Live, and set the dropdown to Verbose. How long ago did the top entry occur?

About a day and a half ago.

Sounds like it hung. What are the top few lines you do see in the Live Log?

Only one line…

Backend event: List - Started: ()

You probably want to restart Duplicati. Out of curiosity what back end type are you using?

How, exactly, should I restart Duplicati in this case? Want to be sure to do it correctly.

Back end is a LAN NAS.

Not sure what OS you are using, or how it’s installed (service, user process, etc). Without knowing that the easiest thing to suggest is to just restart your computer.

Windows 10.

Installed as a single user process, not a service across multiple users.

Do you still suggest to restart the computer?

You can stop Duplicati by right-click on the Duplicati tray icon, then select Quit. Duplicati tray icon may be hidden behind the ^ sign at right hand side of the tray bar.
To restart Duplicati double click C:\Program Files\Duplicati 2\Duplicati.GUI.TrayIcon.exe.
Use Task Manager to see, what´s happening.

If Duplicati is stuck in an operation, Quit from the tray icon may not work. You may need to kill it from Task Manager. If you’re unsure how to do that, just do a restart.

I quit from Duplicati tray icon and rebooted the PC.

I re-loaded Duplicati and click “Verify files” again.

Once again, stuck on “Starting backup…” for several hours.

No change. Still stuck.



Is it still asking for a list then not getting it? If so, is LAN NAS accessed by UNC path, drive letter, what?
How does a list run by other means, e.g. Command Prompt from same PC, done as Duplicati’s user?

Duplicati has no SMB client. It’s just asking for a directory list to Windows, and apparently not getting it.

If you would like to watch the request at a low level in Windows, Sysinternals Process Monitor can do it.

You can test list (but not see result – it doesn’t care) with Test connection button on Destination.

You can test Duplicati list all by itself with Duplicati.CommandLine.BackendTool.exe, e.g. using the URL from Export As Command-line. For a more thorough test, Duplicati.CommandLine.BackendTester.exe does a rather brief (by default) automated test. Give it a Target URL adjusted to point to an empty folder.

Not sure how to answer that.

Live Verbose log only has one line:

Backend event: List - Started: ()

In Duplicati, it’s using FTP

Not sure how to answer this.

Outside of Duplicati, the LAN NAS is accessible via SMB, for things like accessing other files stored on the LAN NAS.

Thanks for these and the other resources in your reply. These resources seem both pretty detailed, but also pretty complex.

Problem solved: Turns out the LAN NAS itself was hung. :man_facepalming: Rebooted it. Did a “Verify files” in Duplicati and it looks like it worked without any issues.

Thank you for your help.

1 Like