Using IPv6 for SFTP (SSH)

Is it possible to use IPv6 address for a host in the SFTP (SSH) setup? I have tried every wasy I can think of from hostname to the IP address in brackets and it all fails.

According to this old (and closed) Github issue it should (unless something got broken between there and here).

So I saw that earlier and had tried the brackets already. Running the command in that thread is useless under linux as it is a windows binary.

Should have mentioned that this is running on a CentOS 7 server.

This issue was opened in 2012, so I suppose it is related to version 1.3. If that’s the case, the issue does not apply to Duplicati 2.

Using brackets with the IP, I get:

Failed to connect: Could not resolve host ‘[2601’

Using no brackets I get:

Failed to connect: The socket is not connected

Using a fqdn in the linux host file, I get:

Failed to connect: Could not resolve host ‘

Using real DNS with a AAAA record, I get this:

Failed to connect: Could not resolve host ‘

Ah…Linux and old stuff - two (of many) things I’m still trying to get better at.

Thanks for the clarification and correction. :slight_smile:

That is really a question for the underlying library “SSH.Net” (aka Renci SSH.Net):

I cannot find anything on IPv6 on the site, but maybe you can open an issue there?