Using Duplicati with Rclone ; how to specify the config file


I’m using my Microsoft OneDrive on Linux Mint with Rclone.
OneDrive appears to be mounted as an external device in my file manager.

I’m trying to backup my “Documents” folder to OneDrive using the Rclone backend.
When choosing the backup location and testing I get the following error :

Failed to connect: Missing config file? 2024/05/14 22:50:19 NOTICE: Config file “/root/.config/rclone/rclone.conf” not found - using defaults2024/05/14 22:50:19 Failed to create file system for “one-drive:Documents”: didn’t find section in config file

The config file is not at the root level but is in my home directory : ~/.config/rclone/rclone.conf
How to get Duplicati use the right config file ?

Thanks !


Words sound unsure. Do you mount it? rclone mount? How and when? What options? Not our area.

Closer to our area, but what does it have to do with the mount? Rclone backend doesn’t need mount.

sounds consistent with the rclone manual about Config:

--config string Config file (default "$HOME/.config/rclone/rclone.conf")


Maybe pass rclone option into Rclone backend?

--rclone-option (String) Options will be transferred to rclone.

There are other ways to try it, e.g. force root Duplicati’s $HOME to yours. That likely moves databases.

You could also make a symbolic link so root rclone config winds up actually going to your rclone config.


If you go with the Advanced option, and it goes away on next Edit, try putting it on screen 5 instead of 3.

Hi @ts678 ,

Thanks for your input ! It solves half of my problems.

So first, when I choose the backup location I’ve added an advanced option :
–config /home/frd/.config/rclone/rclone.conf
Testing connection works now.

Now I’ve still got the problem of selecting the source data.
In the tree view I can access to /home/frd.
No way to get beloww, i. e. to open my directory. Inside there are 11 folders. I just want to backup one of them, which name is “Documents”.

I’ve tried to select my whole home (/home/frd) and exclude the other folders but to no avail.


I suggest you do the things requested in your other topic. I don’t want to repeat things already asked.