Upgraded to latest on Linux, can't log in


Tried to run the upgrade in browser from to latest but it seemed to stick/fail. I downloaded the latest version and ran dpkg -i /tmp/latest-duplicati.deb to install. This may have been a mistake. Does this upgrade or just install over my existing version. In any case I can’t log into the browser. I’ve tried starting the service with sudo duplicati-server --webservice-password=1234 or simply sudo duplicati-server --webservice-password= but no joy. I get a login page and can’t go any further.

Any help greatly appreciated. Note I have command line access only.


You should check if there is possibly a service on port 8300. It’s possible there is another duplicati service running on 8200.

Does that mean you ssh in, and your browser access is remote? If so, maybe you hit this upgrade issue:

Duplicati upgrade - “The host header sent by the client is not allowed”

I’m not sure how far it gets if one hits it though. Above description of failure doesn’t detail symptoms either.

–webservice-allowed-hostnames: The hostnames that are accepted, separated with semicolons. If any of the hostnames are “*”, all hostnames are allowed and the hostname checking is disabled.

as seen on server help, using a “*”, might be a test. I think Settings menu might have a nicer edit interface. Alternatively the issue referenced at the top of this post suggests ssh port forwarding instead of remote on whatever network you have. This is also more secure than opening Duplicati on less-than-trusted network.


Using Debian 9. YMMV. This is intended to be be a single administrator backup solution for my home and as such, using the Linux duplicati server on port 8200 not 8300 (service mode). Took me awhile to figure out the difference and which would be more appropriate. I also installed on my other two windows machines since they’re intended to be the clients and I need the practice. I administer through the web browser on the Linux server itself using localhost:8200.

Are you attempting to access locally or remotely? If locally, did your upgrade any change file permissions? I created a “duplicati” user and added my personal login and duplicati to an already existing group “backup”. Changed target backup directories and other relevant non system duplicati directories to owner=backup rwx, group=backup, world=r-x. This is mainly for security. Everyone else will need to sudo to mess things up, but it could also mess up an upgrade. I also went through the permissions thing setting up Dupllication Windows 10 (much more difficult!) and ran into permission problems mostly of my own making.

Have you done anything else unrelated that could mess up iptables or your AV on any of the servers or client machines?

The only time I need to login (besides admin setup) is first use of the GUI or extended idle time No worries after that.

You didn’t say, but are any of your clients Windows? I’m also going to be setting something like this up for my church full of non-techies and want this to be as simple as possible to understand and use, that’s why I’m going Duplicati. It’s all windows boxes and Duplicati is simple all the way around, but setting up an IIIS vanilla FTP server NOT. You will have to dork with permissions in Windows to just get it to sign on., much less transfer files. Still haven’t gotten it right

It’s just one Ubuntu client backing up to Backblaze (cloud). It was running fine until I attempted this upgrade. Not sure I did it correctly. I can get to a login page but it won’t accept the password…

Yes SSH and remote browser. If I start the service with –webservice-allowed-hostnames=* it allows me access by name but I still can’t log in - it won’t accept my old password (or any other) which makes me think I’ve broken the installation.

Tried 8300 - nothing… :no_mouth:

Thanks for the replies everyone. It’s behaving oddly. I fear I may have upgraded incorrectly and might just remove and start again.

Try typing this at the prompt, it should help you discover what port number it’s listening on:

# netstat -a -p | grep mono   
tcp        0      0  *               LISTEN      22157/mono-sgen

This is from my own system and you can see mono (duplicati) is listening on port 8200.