Update to beta, running as a service, lost all config

Initially this looked like a dupe of Installed New Version - Now Duplicati Won't Run, but it isn’t.

Running on Windows 10, I have Duplicati running as a service. I used the automatic process to update from to After “Activating” the update, the web page could no longer connect to the server, and the tray icon had vanished.

Following the info in the thread linked above I found the newer version of the tray icon in C:\ProgramData\Duplicati\updates\[1]. I added that version to Windows startup, and noted that wheras the old version looked for the server on port 8200, this one uses 8300. That explains why the server couldn’t be found before.

So now the server can be found, but it’s a clean slate, as though it’s the first run. All my existing config, database, etc., has vanished.
I’ve seen this problem before after Windows updates, so I checked C:\windows\system32\config\systemprofile\AppData\Local\Duplicati, but everything is still there - so that isn’t the cause.

Any ideas?


[1] This is REALLY confusing. I’ve been using Duplicati betas for a while, and the version in Program Files is from back in 2017. It surely isn’t considered sustainable to keep putting an ever-growing collection of new versions in ProgramData and leaving the Program Files version alone?

Welcome to the forum @swaldman

Duplicati.GUI.TrayIcon.exe shows how it’s not a change, but dynamic (at least for TrayIcon):

The webserver listens on TCP port 8200 by default. If port 8200 is unavailable, port 8300 is tried, increasing until a free port is found. You can disable the internal webserver if you are using a separate instance of the Duplicati Server component.

Set this option to not spawn a local service, use if the TrayIcon should connect to a running service.

is what you need if you want to have a TrayIcon connect to your Windows service Duplicati, otherwise the connection is to its internal server at whatever port it could get, and with config in the user’s profile.

Your situation sounds like you hadn’t done this before, and so it’s a first-time run in current user profile.

The question is what’s at 8200 and why isn’t it answering? Have you tried restarting the service or PC?

Task Manager or the netstat command might also show you any Duplicati processes that may be there.

What you need to do is to get any Duplicati processes down that are hanging around, then get back up. While some people have had issues getting Duplicati to run (unknown why), it sounds like the TrayIcon started up OK (although in your user profile due to lack of --no-hosted-server), and that’s a good sign…

I believe there is a limit beyond which old ones age off.

Ah! Boh. Thanks. I totally forgot about the --no-hosted-server switch, when moving the startup shortcut to point to the new version.

Navigating to localhost:8200 returned plain text, simply saying “The request queue is full”.
But, having realised what’s going on… I was able to use an elevated command prompt to uninstall the old service and install the new version. Now 8200 responds. On the first connection I got the following error in the Web UI, same as another person on this forum:

Could not load file or assembly ‘Newtonsoft.Json, Version=, Culture=neutral, PublicKeyToken=30ad4fe6b2a6aeed’ or one of its dependencies. The located assembly’s manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)

But it seems to run backups just fine. So, er, thanks for setting me straight, and maybe consider this a bug report that the automatic update doesn’t work for people who are using Duplicati as a service? :wink: