Update broke my Duplicati

Hello guys,
Not so long ago I installed Duplicati on my NAS, configured it and it worked well, uploading backups to the Hubic cloud. And recently, a notification appeared that there is an update, so I pressed the update button and that’s it, the system died. Here is what the console writes after launch, help me to solve this issue.

Here is my NAS system: single core Intel Atom N270 32bit only 2Gb ram, Debian 8 32 bit.

I don’t want to reinstall the entire program, is it possible to fix this update or roll back changes without losing all settings and data? Can I install the latest version of the program on a 32 bit system?

What version of mono are you using?

Ok yeah that is really old. Duplicati 2.0.5.x requires mono 5.10.x or newer. Normally I would direct you to follow the instructions here:

But Debian 8 (Jessie) is not listed. It MAY still work if you use “stable-jessie” instead of “stable-buster”/“stable-stretch” in the instructions, but I’m not sure.

I tried it in a VM and it looks like it works. I get mono 5.18.1 on Debian 8.

Edit - I just remembered that this old VM was targeting Debian “testing” so it may have gotten some pieces of Debian 9. Let me try with a fresh install of Debian 8.

Fresh install worked, I have mono


so, if I update Mono than new version of Duplicati will work?

so, I’ve tried to update a Mono and I’ve got this error messages

it says that:
Packages with unmet dependencies - list of dependencies
depends of: libmono-compilerservices-symbolwriter4.0-cil (>= 3.6.0) but not will be installed
breaks down:libmono-system-configuration-install4.0-cil (< 4.0.0~alpha1-0~) but 3.2.8+dfsg-10+deb8u1will be installed
and so on
in the end says that Unable to correct errors, you have (held) broken packages.

Not really sure what’s going on. Maybe it would help to remove all current mono packages and then install mono-complete from scratch (from the official mono repository).

You may need to temporarily uninstall duplicati so it lets you remove your current mono.

I rolled back to old Duplicati, so right now its over for me, thanks anyways

I think it’s probably resolvable by cleaning old mono and installing the new. I saw another machine where mono didn’t want to transition smoothly to the project’s main repository.