UnRaid 550 Read Only


#1

Hey folks, I’m new to UnRaid 6.3.5 and wanted to have my data backed up to another external NAS on my local network. I went to the appstore within UnRaid and self installed Duplicati with the default options. I set up a nightly backup via FTP and when I try to run it I get the following error:

The folder /shares/duplicati-20180205T143423Z.dlist.zip.aes was not found, message: Server returned an error: 550 Read Only

I don’t understand what’s going on. I’m not a Linux SysAdmin so please go easy on me.

I edited the unraid config for Duplicati to “privilidged” thinking that would help but sadly I get the same error.

Here is my (default) config for Duplicati:

Name:	duplicati
Repository:	linuxserver/duplicati
Network Type:	
Privileged:	ON
Host Port 1:	8200
Container Port: 8200
Host Path 2:	/tmp
Container Path: /tmp
Host Path 3:	/backups
Container Path: /backups
Host Path 4:	/source
Container Path: /source
Key 1:	99
Container Variable: PUID
Key 2:	100
Container Variable: PGID

AppData Config Path:	
/mnt/user/appdata/duplicati

I thought these UnRaid containers are supposed to be plug/play. Do I have to set permissions somewhere? If so, where?


#2

Hi @Boldly_Goes, welcome to the forum!

I’m running unRAID 6.4.0 (just upgraded a few days ago) with a Duplicati Docker but am still in testing mode, so am only backing up a subset of my data both from and to the same array (so no FTP involved).

As a general Docker comment, for some reason what I find most confusing is setting up the mapping of in-container paths to out-of-container paths. So for me (and my test) I have mappings like:

  • /tmp in the container actually hits /mnt/user/appdata/
  • /backups in the container actually hits /mnt/user/Backups/
  • /source in the container actually hits /mnt/user/Data/

Using the Shares tab and the “Browse” icon in the right hand “View” column, I can look at appdata and see there is a Duplicati folder in there which contains things like my .config and control_dir_v2 fodlers as well as Duplicati-server.sqlite and PQGYZDSMOC.sqlite databse files.

Similarly, browsing to my Backups and Shares folders I can see there is Duplicati content or source data) in thise as well.

In your case, I’m a bit concerned by the mappings of the following internal Docker mount points (can’t be changed) to the same names externally: /tmp, /backups, and /source. While there is a /tmp folder in my non-Docker world, there’s no /backups or /source there - so unless you’ve created those on your own system (which would probably be a bad thing since I think that would put them on your USB boot drive) you’re probably going to have problems there.

I’m not really sure why you’re getting a The folder xxxx was not found with reference to a FILE, though. Can you share our Duplicati backup job settings?


#3

Hi @JonMikelV, thank you for all that. Turns out the error was caused by not having correct paths specified. I created a new share called “backups” within my unraid box to test and after double checking and setting the correct paths (same as yours above) things worked with Duplicati to save locally.

Hey Duplicati, why use such non-intuitive labels in the description? My friend that set up the server for me said that when you install dockers you leave them to default settings. This is why I was getting confused because I thought /tmp, /backups, and /source were supposed to be set that way. I think a better approach would be to put more accurate descriptions in the docker config labels so dummies like me would understand you actually wanted me to put.

From another thread on unRaid’s site I opened (https://lime-technology.com/forums/topic/69070-how-to-map-a-network-drive/?do=findComment&comment=633451), I learned how to map network drives to my box and that’s from a plugin called: Unassigned Devices.

After installing the plugin, mounting the external NAS drive on my network, and then added a custom path described in the other thread to make Duplicati “see” the network share. I ran a test and it copied the file chunks correctly without error!

Thanks again!


#4

Glad to hear you got it working!

I’d have to double check, but I believe any Duplicati DockerHub containers listed on the unRAID Apps tab are made by general users. The isn’t one put out by this team.

So better labels are a good idea, but not necessarily under our control. Note that some containers are created at GitHub. If the one you chose is, they you could probably submit a change there with different field names…