University OneDrive Backup Failed Connection


I set up Duplicati to backup files from my PC to my University OneDrive account back in the summer. It worked fine at the time and backed up daily without any issues until last week. I am using version

Just last week it started to fail to back up (see screenshot of error below). The error indicates no connection can be made. If I try to test the connection I get the same error. I tried removing the // in the file path to no avail. I double checked that the path on the OneDrive site did not change and I can confirm it did not. I also verified the password is not wrong (I have not changed my password since the failed connections started and I can still log into my OneDrive via the web).

I am unsure of the next steps to resolve this.

Is it possible Microsoft or my University changed something on their end that caused Duplicati to no longer be able to connect? I would appreciate any help in how I could go about diagnosing and fixing this issue.

Here is what my configuration looks like.

And here is the error I am getting when I try to run the backup. I get this same error when I try to test the connection.

I don’t think we can answer that, but if Duplicati stayed the same, then I guess change was elsewhere.
You’re definitely using the old method. OneDrive already killed their old one, thus there’s OneDrive v2.
Microsoft SharePoint v2 (Microsoft Graph API) may be another option. Both use the newer Graph API.

Thanks for the response.

What do you mean by “old method”? I understood that OneDrive for education was the same as OneDrive for Business which was the option I used when setting up the backup.

I did try with OneDrive v2. But when I try to connect to the folder at /personal/USERNAME//Documents/PhDBackup it tells me the folder does not exist and asks to create it. I’m confused - where then is it trying to create the folder? Because I can log into my university OneDrive account and see where the backups were being stored (up until it started failing to connect).

Migrating from Live SDK to Microsoft Graph is the Microsoft move that killed the original OneDrive API.

OneDrive failing : “The remote server returned an error: (410) Gone.” is the way that failed in Duplicati.

It looks like the old SharePoint API lives longer, but there’s also a newer API based on Microsoft Graph which some Duplicati users have used when the old API shows problems, and that was the suggestion. Current error might be easier to debug.

I don’t know their confusing product line, with numerous highly different things branded under OneDrive. What your university is using is also unknown to me, though some education version seems plausible…

I don’t personally have access to any such things, so help may be limited unless somebody else does it.

Now that at least it is letting you in, you can see what you can see from whatever location server used.

On the job menu, try Verify files then go to the job menu Show log → Remote to expand that list. Possibly you’ll recognize something. I vaguely recall other weirdnesses, but I forget whether it was with OneDrive or Google. Some people have also been subject to things administrators did and wouldn’t fix.

I don’t know what layout you see, or what’s normal. In original image, is personal a top-level folder?
What’s the redaction that follows it, and why is there a double rather than single slash following that?


About OneDrive URLs (which seems written for an organization setup, which seems right for this use)
suggests that the path redaction is the user (you), so maybe Documents is your top-level folder seen?
That still doesn’t explain the double slash, and it’s also not clear you must give user path to OneDrive.

If I misunderstand the conventions or what you see, please clarify. The requested test might also help.

If you don’t mind command line …

Export As Command-line and edit the URL to Duplicati.CommandLine.BackendTool.exe get.
Basically, once you’re in, you need to figure out where you are by trying some different paths.

Thanks - I tried it. Unfortunately when I try to Verify files it just fails and shows the message I copy/pasted into the OP. Nothing new in the log shows up. I looked in both General and Remote.

So I got that path by going into the web interface of OneDrive. I navigate to the folder where my backups were being stored, click on the last successful one and then go to Details. In there I can do a copy path button which gives the following: I understood the // was to separate the URL path from the file path. I’m not sure where I read that. But it doesn’t make a difference either way.

I should note, the path above does not appear to match what is actually in the address bar when I am navigating the web version which looks something like this: Not sure if that matters at all.

One thing I just noticed. When I exported the configuration I saw that the password it is using to access my University OneDrive account is not the latest (I changed it back in August maybe?). I have no idea why it would have kept working till now. But even updating my password in the configure backup page (which I had already tried) still does not resolve the issue. I get the same error.

That’s when you were on Microsoft OneDrive for Business.
You’re supposed to be testing out new method that allows you in:

which suggests it did a list, which you can do to see what it saw.
If GUI is too multi-step, there was also a command line way given.

That’s a clue you’re trying the old way. New doesn’t use password.
You give credentials to Microsoft, and Duplicati stores it via AuthID.

Please switch to a way that lets you in, to figure out where you are.

Thank you.

I appear to have fixed it. I will explain how.

Under configuration I changed to OneDrive v2.
Then I clicked the authID field and it took me to my University login page.
I logged in and Duplicati copied the authID into the field in the backup configuration.

Then, for whatever reason, I had to update the path I was using. Instead of /personal/USERNAME/Documents/PhDBackup/ I had to only do PhDBackup (so that backups would go into the correct folder where they had been being saved). If I used the old path then at the top level I would have a new folder structure created called /personal/USERNAME/Documents/PhDBackup which was not what I wanted (not the same folder!). Hopefully that makes sense and is helpful to anyone who encounters this in the future.