"Unexpected difference in fileset version 63", then 61, 60, 59

Hi guys,

just got the dreaded difference in fileset error (“Unexpected difference in fileset version 63: 17.10.2020 11:28:58 (database id: 1025), found 33357 entries, but expected 33389”), possibly due to a lost network connection during the backup.

I followed the instructions is other posts, deleted version 63, but when I tried to run the backup again, it gave me a similar error for version 61. I deleted 61, then it complains about 60, then 59, … you get the picture.

Should I really keep deleting these versions, or what else can I do?

Thanks in advance for any pointers,

I usually recommend deleting the offending version, but others have had success with database recreation. You might want to try database recreation at this point. But before you do, back up the existing database just in case.

Hi, thanks for your reply and your help!
Just to confirm (since it’s the first time I’m doing this): backing up the existing database means copying all duplicati* files manually from the “Path on server” directory, correct?

No those are the remote files. The job database is a local file, randomly named file with a .sqlite extension. The local job database file can be recreated by reading the remote files, so it’s generally safe to delete. But to be safe you can just rename it or back it up in case the recreation fails.

To find out where your local database is, click the job in the main Duplicati Web UI, then click the blue “Database …” link:


This is also where you go to initiate the Recreate operation.

Thanks a lot for the clarification!
I followed your advice and I think it all worked.
After recreating the database I got the message “Recreated database has missing blocks and 59 broken filelists. Consider using “list-broken-files” and “purge-broken-files” to purge broken data from the remote store and the database.”
I checked how to run “list-broken-files” and “purge-broken-files”, and after running both the database seems ok, and a subsequent backup run also seems to have finished successfully without any further problems.
Thanks again for your help!
All the best,

1 Like