Unexpected difference in fileset version 1

I just got

Unexpected difference in fileset version 1: 3/19/2020 9:21:19 AM (database id: 131), found 1732868 entries, but expected 1732952

I don’t get a log, just this one error and the backup aborts. Running it again gives the same result. Plenty of filesystem space.

This is on running on Ubuntu 18.04. I see there are posting from a year or more back and earlier releases.

How do I recover?

Of course that title should say UNexpected, I haven’t gotten a response in two days, waiting for some help on how to proceed. I just get the same error on every backup with an early abort.

Out of curiosity, did you get this error and then upgrade to to try and resolve it? Or have you been running a while and then this problem appeared?

In any case, the most straight forward solution is to just delete the offending version.

In the Duplicati Web UI, click on your backup set to expand the options, then click the blue “Commandline…” link:


On the next page, change the Command dropdown to “delete” and replace the contents of the Commandline arguments box with --version=1 (Since that is the version you are getting an error about.)

Then scroll to the bottom of the page and click the blue “Run “Delete” command now” button.

The Delete worked! Thanks for the detailed instructions.

It took 4 hours. The next backup which had a few days of work to catch up to took 10, and the one after that about 8.

I am confused about the version issue. I have been running successfully for some time, and after the delete “about” still says the same thing. Is the “fileset version” a different version space?

Yeah the “version” you deleted is a backup version. Each backup version represents a point in time from which you can restore. Version 0 is the most recent, version 1 is the next older one, and so on. You can see how many backup “versions” you have by looking at the summary screen for your backup job. Where it shows the Backup size you’ll also see the version count.

Hope this helps!