Unable to send via gmail

Tried multiple different configs found here on the forum and elsewhere.
But I’m unable to get it work.
Tried with multiple smtp ports.
Gmail account with 2FA and app password
Unsecure Gmail account with no F2A and ‘Less secure apps’ activated, with normal pwd.

Testing from ‘http://url:port/ngax/index.html#/commandline’, and always get the same response:

Failed to send message: System.Net.Sockets.SocketException: Could not resolve host ‘smtp.gmail.com
=> Could not resolve host ‘smtp.gmail.com
Return code: 0


Running in 2.0.5 in docker.

Welcome to the forum @blahtrip

The different configs and ports mostly come into play after host is known and connected, but you’re at

so never really got going. How do other network tools work, for example doing ping smtp.gmail.com?
I’m not sure what DNS utilities are in your Docker (and where is it from)? If all else fails, bash might do.
This example is total nonsense from a protocol point of view, but is one way to get bash to do a lookup:

$ < /dev/udp/smtp.gmail.com/80
$ < /dev/udp/fail.gmail.com/80
bash: fail.gmail.com: Name or service not known
bash: /dev/udp/fail.gmail.com/80: Invalid argument

What Storage Type is on your destination. Some of those should have failed first if DNS is really down.
Or are you testing just The SEND-MAIL command, e.g. to get that part solved before setting up backup?

I was just testing the send mail command.
I apparently had some DNS issues, after fixing this by using Google’s DNS, everything seems to work. Thank you.