Unable to install duplicati_2.0.6.103-1_all.deb on Raspberry Pi running on Buster

I am unable to install the new release. I get the below error:

Also zstd is already installed.

Does anyone else have this issue, or is it just me?

Edit:
I can see an issue has been raised for this already. Just posting the link to the issue here for anyone who might want to look at it:

installing a decompression utility for a given algorithm will not enable a software to use the said algorithm, it has to be compiled in, like setting a battery into your gas car will not allow you to use a Tesla charging station. This is a known and old Debian problem.. You can switch to Ubuntu, repackage the deb, or build from source.

1 Like

I was able to install on Debian 11 by repackaging the deb. Here is the recipe I used. You do need to install the zstd package first.

wget https://github.com/duplicati/duplicati/releases/download/v2.0.6.104-2.0.6.104_canary_2022-06-15/duplicati_2.0.6.104-1_all.deb
mkdir deb-temp
cd deb-temp
ar x ../duplicati_2.0.6.104-1_all.deb
zstd -d *.zst
rm *.zst
xz *.tar
ar r ../duplicati_2.0.6.104-1_all-XZ.deb debian-binary control.tar.xz data.tar.xz
cd ..
apt install ./duplicati_2.0.6.104-1_all-XZ.deb
3 Likes

Thanks @drwtsn32

That worked for me.

1 Like

Also worked for me, thanks very much

1 Like

That looks like bullseye the latest stable from August 2021, so can’t complain the distro is ancient.

I’m not seeing a post in that thread that it’s been supported, even in upcoming Debian 12 bookworm.

There were some posts saying Ubuntu build tools switched to zstd by default, maybe in 2021-06-14.
I’m not sure where that is from. Hello zstd compressed .debs in Ubuntu! said it was targetting 21.10.
I wonder if the build machine changed but should (for maximum compatibility) override zstd default?

Unknown compression error when installing latest canary on Debian #4743 is wondering this as well:

… since I don’t find any specific commit that could influence the building of the deb file I’m thinking that maybe something changed on the build process you use for building the releases?

Anybody care to figure out how badly staying with zstd will hurt us, and how to override default build?
How do I build a .deb without zstd compression in Ubuntu 21.10? might be this issue, with a solution.

I’m tempted to think this undocumented and maybe accidental change would be better off reverted…

Repackaging workaround is nice, but doesn’t scale well if forum help has to lead everyone through it.
That’s possible for Canary, but it would be best to give Canary release note feedback before its Beta.

What do the Linux experts think is the better path? From a support view, least issues is the best path.

1 Like

I agree, unless there is some reason we’re not aware of to prefer zstd.

I got curious and looked up the last build.

dpkg -e duplicati_2.0.6.104-1_all.deb
grep dh_install DEBIAN/postinst
# Automatically added by dh_installinit/13.6ubuntu1

dh_installinit is a Perl script part of debhelper. So to know on which system the last deb package was built, it’s enough to know the debhelper version for a few Ubuntu versions. 20.04 has 11.1 so it’s too old. 22.04 LTS matches. My guess is that the Duplicati maintainer has setup is WSL system with the last Ubuntu version, that is, 22.04 (it’s picked automatically by WSL I think)

So to get a Debian friendly package, I’d hasard to say that it would probably enough to pick explicitly 20.04 instead of asking only for Ubuntu, there: Install WSL | Microsoft Docs

Now I have not used WSL at any point in my life, and I have alas no clue how to build the deb package (there is a build-package.sh command that looks like it could work, and from a Github issue I’m too lazy to lookup now, it even used to work - in 2014. But I have not been able to make it work in 2022. So I have not tested any of this.