Unable to complete backup in b2 backblaze


I’ve been trying b2 backblaze for personal backup as a free user for know. I can’t complete the initial test upload (about 500M). I use debian bullseye/sid with duplicati

It seems to upload data from what the network monitor shows, but never until the end. The error message is not always the same. I then activated logging, and found a lot of retries such as :

[Retry-Duplicati.Library.Main.Operation.Backup.BackendUploader-RetryPut]: Operation Put with file duplicati-b71cd89e3fc4b44ccac7f57903ca332dc.dblock.zip.aes attempt 4 of 5 failed with message: Error getting response stream (ReadDoneAsync2): ReceiveFailure
System.Net.WebException: Error getting response stream (ReadDoneAsync2): ReceiveFailure

[Retry-Duplicati.Library.Main.Operation.Backup.BackendUploader-RetryPut]: Operation Put with file duplicati-ba9f33ad54c7d4937b6b199f626ca005d.dblock.zip.aes attempt 2 of 5 failed with message: Error: SecureChannelFailure (Remote prematurely closed connection.)
System.Net.WebException: Error: SecureChannelFailure (Remote prematurely closed connection.) —> System.IO.IOException: Remote prematurely closed connection.

edit : last time i tried to run the backup, it wouldn’t start: Unexpected difference in fileset version 1: 2/25/2021 3:14:31 PM (database id: 1), found 1124 entries, but expected 1757
(I fixed this error with a repair)

I tried to backup the same data in a local folder and in wasabi without any problem.

Since I’m far from being the first to try the duplicati/B2 setup, I suppose I should make it work.

Could it be that since I’m testing backblaze as a free user, my puts are not treated as top priority ? I guess not since that would defeat the hole point of testing for free.

Could it be because of a somewhat unstable connection ?

Any suggestion appreciated.

The Free tier is limited to 10GB. Can you check the B2 console to see if you’ve consumed that space? I know you say your backup is 500MB, but it would be good to double check the B2 console. (I don’t really know how B2 behaves when you hit 10GB though…)

If the 10GB limit isn’t the issue, then I would guess it is your connection stability based on the error messages. Do you notice any other problems with other services/sites online?

You name two dblock files. There’s a dindex per dblock. Do they do better? Is remote volume size 50 MB?

Uploading sounds like you should get a 400 or 403 error. This does sound like a connectivity problem, but Wasabi working well seems odd. You could run Duplicati.CommandLine.BackendTester.exe to B2 using Export As Command-line and adjusting the Target URL to point to an empty path. See how well that does.

I checked the B2 console: below 1G

I might have had connectivity issues on a public network, but trying from a more sable and private netwok didn’t improve the upload. I couldn’t complete the 500M upload.

Here are the errors I get. http://sprunge.us/p0Kczb The remote volume size is 50MB.

I ran BackendTester.exe. I had to cancel the 2 first tries (irrelevant reasons) but here are the logs. http://sprunge.us/w0QpHv http://sprunge.us/LcZwuv
Here is the complete run: http://sprunge.us/M5PU44 (in the end, the 1G Daily Download Bandwidth Cap was reached)

edit: I can also mention that the progression bar seems off. The storage size to upload decreases much too fast for my connection, and then gets stuck to a few KB for a while, until a fatal error. 200MB were uploaded. The progression bar seems ok on Wasabi.