Unable to acess pCloudDrive as backup location on Linux Mint

I’m using Duplicati on a windows 11 computer and the backup location is set to my pCloudDrive on the computer. So the files go straight to my pCloud account. No problems so far.
I have a second computer, an old one so I’ve insrtalled Linux Mint as OS.
I want to have the same configuration on this machine : to set the backup location on a folder on my pCloud account using the pCloudDrive in my home directory.
But when I choose the backup location (when creating a new backup) I can’t access to my folder pCloudDrive. Even when I manually enter the location : /home/frd/pCloudDrive.

Any help appreciated.


Welcome to the forum @frd

What do you see and do? What happens at stop?

How far can you access, going down in that path?

After that, can you see it but not enter, or not see?

Is the UserName in About → System info allowed, e.g. looking at permissions on the folder (e.g. ls -ld)?

Is the same user able to get access from a shell?

Hi @ts678
When creating a new backup I have to choose the destination.
At this step I cannot open my home folder to choose my pCloudDrive folder.
I tried another way : as my pCloudDrive foler also is mounted as an external drive I tried to select via /media. But there I can only see my USB key.

By the way when selecting the source, I cannot go inside my home directory and select for instance my “Documents” folder.

About permissions, it seems that Duplicati is running as root so I don’t see why it cannot see inside my home directory or see an external drive.


Still unclear.

So you can (for example) see /home in the tree view, but without this right-arrow to click-open?


Or do you mean you can select above, then Test connection gives an error (what), or what?

Words sound unsure. Is that from UserName? You can also look other ways, such as using ps.

Do you know how you are starting Duplicati? For example is it systemd, or manual after login?
You can get a clue by About → System info StartedBy field.

Make certain it’s actualy root. Anything on local should respect root, but pCloud Drive might not.

has not been tried either. Do you need help with this?


For example of why pCloud Drive might not be accessible by root, Google found this information:

but this is not pCloud Support, so it would be best to either study further, or test as root, as asked.

Hi @ts678

I can see /home in the treeview, with its right-arrow, and when I click on it , it shows my home directory : frd with a right-arrow. That’s as far as I can go. I cannot open further and see inside my directory.

I started Duplicati by typing “sudo systemctl start duplicati” in a terminal and then opened a new window in the browser : “”.

I saw root was the owner of the Duplicati process with the “ps” comand.

Tnahks for the link ! Maybe I’ll use Rclone to connect to pCloud instead of the proprietary software. But I have probems too with Rclone (see another post in the forum …)


If I follow, /home has a right arrow which opens to show frd which has a right arrow that won’t open?

Does /home/frd have files in it besides pCloudDrive? If not, this may be pCloudDrive root limitation.

Could mean you successfully opened and then saw everything inside directory – thus nothing – but:

and from it, I’m not sure if it means it’s invisible to root, or visible but can’t be opened. You can test it.

Hi @ts678

@ts678 :
If I follow, /home has a right arrow which opens to show frd which has a right arrow that won’t open?


@ts678 :
Does /home/frd have files in it besides pCloudDrive?

Yes. There are 10 more folders and a single document.
Capture d’écran du 2024-05-15 14-04-19

I want only “Documents” to be baked up by Duplicati.


Hi @ts678

I’ve found the solution in order to select the source data.
In the screen about source data, I select /home/frd/ in the treeview, and then add a path : /home/frd/Documents/
Then it works like a charm !
It was just me not really understanding the graphic interface of this screen. :grimacing:

Thanks a lot for your help and your patience.


So an on-local-drive document, some local-drive OS folders, and two virtual drives it appears.

Root Duplicati can’t see any, I hear. Can a root shell (e.g from sudo su -)? Just confirming it.
Duplicati “should” get the same access, when run as the same user. If not, it seems strange.

We’re sort of in similar questions to Destination, except “select” means a checkmark on folder.

I was going to ask for similar see-and-do info on the problem, but now the solution puzzles me.

If you’re having to use combination of the tree view and Add path, that still seems pretty weird.

Usually you should be able to go all the way either expanding the tree view or going right to path.

I think. I’m not on Linux much, and there are some brand new questions above on what’s local.

Regardless, I’m glad you got there, but I don’t know why you had to get there the way it sounds.