I’m encountering the following errors when attempting to run a backup job under Ubuntu 18.04 LTS. Mono version is 184.108.40.206. Duplicati - 220.127.116.11_beta_2023-05-25
(in Web interface)
Could not load file or assembly ‘netstandard, Version=18.104.22.168, Culture=neutral, PublicKeyToken=cc7b13ffcd2ddd51’ or one of its dependencies.
(at Ubuntu command line)
Failed to load module “canberra-gtk-module”
Failed to send notification: System.IO.FileNotFoundException: Could not load file or assembly ‘notify-sharp, Version=0.4.0.0, Culture=neutral, PublicKeyToken=2df29c54e245917a’ or one of its dependencies.
File name: ‘notify-sharp, Version=0.4.0.0, Culture=neutral, PublicKeyToken=2df29c54e245917a’
at Duplicati.GUI.TrayIcon.GtkRunner.NotifyUser (System.String title, System.String message, Duplicati.GUI.TrayIcon.NotificationType type) [0x00002] in <9128bf13baf6406fa6155e78725fe6c0>:0
netstandard is part of Mono. Mono itself is loaded in Ubuntu using a PPA, that is, it’s basically not supported in any way by Ubuntu. This means that to get support, you have to rely on Mono and exclusively on Mono. And it’s not realist to expect Mono to support an obsolete operating system.
In other words, sorry, but it will most probably not work.
Supported by this forum post and a 2013 decision from the mono devs, still with an open issue on
Please see if following the installation directions provides you with assemblies reported as missing.
Attempting to trace with dpkg and apt series of tools gave a clearer answer for mono than graphics.
No its a new install. I encounter these errors when trying to install those packages:
The following packages have unmet dependencies:
gtk-sharp2-gapi : Depends: libc6 (>= 2.31) but 2.27-3ubuntu1.6 is to be installed or
libc6.1 (>= 2.31) but it is not installable or
libc0.1 (>= 2.31) but it is not installable
libgdiplus : Depends: libc6 (>= 2.29) but 2.27-3ubuntu1.6 is to be installed
libglib2.0-cil : Depends: libglib2.0-0 (>= 2.64.1) but 2.56.4-0ubuntu0.18.04.9 is to be installed
libgtk2.0-cil : Depends: libatk1.0-0 (>= 2.35.1) but 2.28.1-1 is to be installed
Depends: libgdk-pixbuf2.0-0 (>= 2.40.0+dfsg) but 2.36.11-2 is to be installed
Depends: libglib2.0-0 (>= 2.64.1) but 2.56.4-0ubuntu0.18.04.9 is to be installed
Depends: libpango-1.0-0 (>= 1.44.7) but 1.40.14-1ubuntu0.1 is to be installed
Depends: libpangocairo-1.0-0 (>= 1.44.7) but 1.40.14-1ubuntu0.1 is to be installed
I think this means I need to update to ubuntu 22 but I’m not sure. Instructions on the duplicati site don’t mention the minimum OS version.