Two DBs, one doing full, the other doing partial

I have two databases on Duplicati.
Each DB /job is in charge of backing up only a single file.

My first DB seems to be doing full backups, however, my second DB/job only did a full backup the first time, and is now doing only partial backups.

Any ideas why?

Both have the same exact settings, no special flags / parameters set. They’re just saving two different files and then uploading via SFTP to another server.

Also both are using GNU encryption, with Smart Backup Retention enabled.

DB #1:
DB #2:

This may help give you something to investigate before someone like ts678 comes along with a lot more detailed information. :slight_smile:

The “partial” you are seeing is not an indication of “full” vs “incremental” backup type like you see with many backup applications. Duplicati always does incremental backups.

I believe what you are seeing is that those backups were interrupted as in “incomplete” not “incremental”. Did you try to stop them after they had started? Maybe the system crashed? You may be able to find something interesting in the log for that backup job under “Reporting:” → “Show log”.

1 Like

I just checked the log for local and remote and it seems to be successful, and when I just ran another backup; no errors popped up.

So it appears as if it’s doing it properly. I’ll restart the services and run another. It’s odd because the first job backs up fine, just the second one does the partial thing; and there’s nothing different about the two.

Never tried stopping the service mid backup.

The general log shows no errors, no warnings, and success on the action, and then the complete log lists everything as successful, with no warnings or errors neither. GPG was executed in the right path, checked for old backups, nothing out the norm.

I’ve tried repairing the database / delete + repair; I’ve checked the settings 10 times. Restarted the service.

I don’t know what happened, but I restarted the destination server that Duplicati is uploading to, and it started working. Not sure what happened. Seems odd considering the server doesn’t have anything with Duplicati installed; other than the FTP server.

Do you have the information from the September 29 9:00pm backup?

Sadly, no. All the logs are from today. I think I may have cleared them out prior to finding out about this issue. Lesson learned. Wish I didn’t. Would be nice to know what happened for future reference.

That was the original motive behind “partial”, but there might be other ways to get there. Need logs.

add handling of a partial backup
Fix ‘stop after current file’ #3836

Recreating the database would clear job logs. Fortunately there’s also a difficult-to-clear server log.
Viewing the Duplicati Server Logs at About → Show log → Stored tends to show info for failed jobs.
This can correspond to missing job log. If you know your run schedule, see if there are any oddities.
If this happens a lot, consider setting up a log-file=<path> log-file-log-level=information (for starters).

In addition to above, does FTP server keep logs? If not, do the dlist file timestamps seem normal?
Ordinarily a dlist file uploads at the end of a backup, but if interrupted may upload at start of next one.
Note that the timestamp in the dlist filename is in UTC. Maybe you can compare a partial to a normal.