Trying to backup to network share - having problems

Hello all

I’m new to Duplicati and trying to get my head around it but really struggling.

I’m running Duplicati - not as a service.

I’m trying to create a backup of photos and videos only from one server (servera) to a network share on another (backupserver).

Firstly, I have created a share on the backup server \photosbackup where I want the backup to be stored.

In Duplicati I’m given the choice of local folder or drive where shares on servera are listed. However, I want to backup to the backup server. If I manually type the path: \backupserver\photosbackup and test the connection it works.
However, when I try to run the backup I get the following error:
Object must be a root directory (“C:”) or a drive letter (“C”).

The other options listed don’t make much sense to me FTP etc and I can’t work out why it’s not working. I have tried looking for some detailed user guides on Duplicati but am not having much luck.

Any help would be great.


Hi all,

I’ve been digging a little deeper into the issue.

It appears the school where I work had previous backups set up to copy all photos and video from our main server to our back up server. The were scheduled to run every night at 7.00pm. However, these stopped running on 29/07/2017. I’ve just tried to run it again and the same error appears! Really confused. :confused:

This is a known issue that should be fixed in the next Canary build:

Thank you. I thought I was going mad to be honest! Do we have any idea when the latest build will be released? Many, many thanks.


Should be very soon. @kenkendk just commented to another issue:

Wow, amazing! Thank you! :smiley:

Just to let you know, I receive the same error when trying to restore files from a network share.

Thank you for all your hard work.


New Canary v2.0.2.10 released a few minutes ago.

Can you update to this version and report if it solved your problem?

Hi, yes it fixed it! Thank you! :smiley:

1 Like