Trigger rewrite of all remote volumes after --dblock-size change

Just getting started with Duplicati. Since I jumped right in without reading all the documentation, I made the mistake of setting the “Upload Volume Size” to 750 GB, thinking that it was the available space on the server. Now, with a single dblock file of 54GB, it takes a long time to restore a file.

I have changed the “Upload Volume Size” to 50MB and have set --dblock-size to the same value. Is there now a way for me to force the download and rewrite of the backup?

I have tried “Compact” with --threshold set to 1, but since the backup was compacted very recently (just before I made the change) that did not work. I could just wait for it to (presumably) get re-written over time, but I would prefer to pay the price for my mistake now and get quicker access to restore files.


You might just go ahead and set up a whole new backup set (export your folders/etc from the configuration of the original one), and then set your original one to not run automatically again. Then after the data has finished backing up in your new configuration, you can delete the old backup + data when you’re ready.

That is a reasonable suggestion and I may go ahead and do that – although I would prefer not to lose the ~2 months of versions I have in the current backup.

I have just tried setting threshold to zero and rerunning compact and based on how long it has been displaying “Starting…” it appears that may do the trick. I will report back in the next day or so whether that worked.

1 Like