Tardigrade to Storj DCS

Hi,
I update my duplicati dock to 2.0.6.100_canary_2021-08-11 and got the warning “Tardigrade-backend got renamed to Storj DCS” and asking me to migrate by changing the destination storage type to Storj DCS. I had to put in the API key again and the bucket. When I tested the connection I received a message fill in encryption passphrase. I am not using encryption and don’t remember filling this in. I put in a passphrase to see what would happen and got this error.

Failed to connect: uplink: node id is required in satelliteNodeURL storj.io/uplink.parseNodeURL:212 storj.io/uplink.Config.requestAccessWithPassphraseAndConcurrency:161 storj.io/uplink.Config.RequestAccessWithPassphrase:148 main.uplink_config_request_access_with_passphrase:38 main._cgoexpwrap_9685c5e68192_uplink_config_request_access_with_passphrase:765 runtime.cgocallbackg1:332 runtime.cgocallbackg:207 runtime.cgocallback_gofunc:794

If I did put in a passphrase I don’t remember it and it is not in the exported configuration files so I believe there was not one before this.

Any ideas what is wrong?

Thanks for your help. Things have been flawless with the software so far.

Ed

I’m not sure. I’ve only used the “access grant” authentication method, which doesn’t require the encryption passphrase to be provided separately.

@TopperDEL, any ideas?

Are you sure that you have an API-key here? Feels more like this is an access grant.
If you open your current configuration (before migration), does the “Authentication method”-dropdown show Access grant or API-Key?
I’m using Acces grant here, too, and when I migrated my configs, the Authentication method flipped over to API-key when I changed the backend-type. So maybe just try using “access grant” as authentication method.

If this is an API-key and you don’t have your encryption passphrase anymore, then I’m sorry. That would mean that the data is lost as no-one could bring that passphrase back.
The new version of the backend has a password-verify-field to make sure you enter the correct passphrase (as you now have to enter it twice).

Wish you the best that what you have is an access grant.

I did some more testing after reading your replies. I do have a passphrase stored in the browser and tried using it. When I have the storage type as 'Tardigrade Decentralized Cloud Storage (Deprecated) it works. When I switch over to ‘Storj DCS (Decentralized Cloud Storage)’ with that same passphrase I get the same error I posted in my first post. If I import the saved config it works on 2.0.6.100_canary_2021-08-11 with the old name but not when I try to use new storage name, Storj DCS.

I don’t know about Acces grant and will have to read how to set that up if I have to switch over to Storj DCS

Thanks

Follow up.
Made an access grant for the bucket and that worked. Back up and restores are working good.

I don’t know what happened with the API key that only worked with the old site name but it is working with the access grant for Storj DCS.

Thanks for your help.

Ed