Synology use another path

Hello all,

I’ve upgraded my Duplicati syno from to by removing the old one, reboot the NAS and install the new one.
Bad luck, I don’t remember how was my previous config.
What I see, is that I have a “homemade” backup folder containing :

├── CZPSAAGTGX.sqlite
├── Duplicati-server.sqlite
├── control_dir_v2
│   └── lock_v2

How can I tell to the new Duplicati version to use this folder ? Because now, it’s using /root/.config/Duplicati/

When I ran the native Duplicati package on my Synology, I would use a symlink. First, stop the Duplicati package so it is not running. Then ssh to your NAS as root and do something like this:

# cd /root/.config
# ln -s /volume1/backupconfigfolder Duplicati

You may need to remove any existing Duplicati folder before you can create the symlink. Use caution so you don’t delete anything important.

Other thing to note - Duplicati 2.0.5.x requires Mono 5.x or newer. You cannot use the Mono package provided by the standard Synology package repository as it’s too old. You should remove that Mono package and install the one from

Once you have the newer Mono version installed, restart Duplicati package and it should use the correct data folder pointed to by your symlink.

This symlink may need to be recreated every now and then. Major DSM upgrades like to wipe out the /root/.config area.

Thanks for your reply.
I thought it was an option to change the path. Ok to use a symlink, is it persistent to reboot ?

Weird, I’ve try to make a small backup of one file, and it works with the old version of Mono, but I had to update certificate with cert-sync.

Right now, I’ve decided to move to docker in Synology because for not modify the syno system (use symlink for exemple) and to get a easy reusable method to reinstall/upgrade it

On other platforms you could pass a command line option on startup to have Duplicati use a different path. But I don’t think you can do that with a regular Synology package.

So people have done workarounds… Symlink is one, another is to start Duplicati on boot using task scheduler where you can specify command line options.

In my experience the symlink survived reboots but not major DSM upgrades. I trained myself to check after upgrades. (By the way you don’t have to reboot your nas to install a Duplicati upgrade.)

Nowadays I run Duplicati in a docker container on my Synology and avoid these problems (but there are new challenges if you’re unfamiliar with docker).

I think it’s possible to change the command line start, we just have to edit the start-stop-status script.
Because I uninstall the previous version, I had to reboot because when I installed the new one, the Syno show me the latest version but in Duplicati about page, it’s still show me the old one … I think it was in memory because I tried to manually remove all the remaining files :


I’m familiar with Docker so it’s just took me few minutes to get it works with the duplicati/duplicati image. But I facing upload speed issue. It’s very long … 1,5MB/s (obvsiouly it’s not my ISP connection).