Synology to Amazon Glacier

I am setting up Dupliciti on my Synology NAS. I am going to point to Amazon Glacier, or Amazon Drive.

I am testing Amazon Glacier first, but am having issues. I keep getting permission errors. I have created the IAM user for it, and gave it access to the GlacierFullAccess group. I believe this is a security setting on Amazon, but not sure what group to add. I assume the setup is correct.

Any ideas?

Thanks in advance.

What are the actual permission errors and can you tell if they are from Duplicati or Amazon?

Note that compared to Amazon Drive using Glacier as a destination requires some extra settings due to the limited ability to access and update files. Did you notice if this issue was mentioned on any of the other Glacier related topics?



Hi Jon,

Thanks for the quick reply… I tried searching and could not find anything. I was able to get the answer to a different question on here when trying to install Dupliciti on my NAS.

I am beginning to think that I should just use Amazon Drive. It would just cost more I think/assume.

The permission errors are on Amazon side I believe. Altho I gave it root access keys, and it still did not work. I get the error “Not Allowed” in dupliciti. I tried with SSL enabled and disabled.

Thanks for any help.

Not sure what the issue is, but Duplicati does not directly access Glacier.
Instead it uploads files to S3 and then uses the Life Cycle Rules to move the files to Glacier for long-term storage.

Getting files out of Glacier is a bit of a pain, so I generally recommend not using it with Duplicati.

There is some more discussion here: Amazon Glacier support · Issue #701 · duplicati/duplicati · GitHub